<!doctype html><html lang=en-US><head><meta charset=UTF-8><meta name=viewport content="width=device-width, initial-scale=1"><link rel=profile href=https://gmpg.org/xfn/11><link media=all href=https://liliputing.com/wp-content/cache/autoptimize/autoptimize_36ded51b80d6dbefe281fb7370330ee7.php rel=stylesheet><link media=print href=https://liliputing.com/wp-content/cache/autoptimize/autoptimize_57c0a5a078b85e9c217554d0abe624fb.php rel=stylesheet><title>Motorola Razr (2020) goes on sale Oct 2 for $1200 - Liliputing</title><meta name=description content="Motorola Razr (2020) goes on sale Oct 2 for $1200"><meta name=robots content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1"><link rel=canonical href=https://liliputing.com/2020/09/motorola-razr-2020-goes-on-sale-oct-2-for-1200.html><meta property=og:locale content=en_US><meta property=og:type content=article><meta property=og:title content="Motorola Razr (2020) goes on sale Oct 2 for $1200 - Liliputing"><meta property=og:description content="Motorola Razr (2020) goes on sale Oct 2 for $1200"><meta property=og:url content=https://liliputing.com/2020/09/motorola-razr-2020-goes-on-sale-oct-2-for-1200.html><meta property=og:site_name content=Liliputing><meta property=article:publisher content=https://www.facebook.com/Liliputing><meta property=article:published_time content=2020-09-29T16:20:58+00:00><meta property=og:image content=https://liliputing.com/wp-content/uploads/2020/09/razr-5g_07-1.jpg><meta property=og:image:width content=1200><meta property=og:image:height content=1039><meta name=twitter:card content=summary><meta name=twitter:creator content=@bradlinder><meta name=twitter:site content=@liliputingnews> <script type=application/ld+json class=yoast-schema-graph>{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://liliputing.com/#organization","name":"Liliputing","url":"https://liliputing.com/","sameAs":["https://www.facebook.com/Liliputing","https://www.youtube.com/liliputing","https://twitter.com/liliputingnews"],"logo":{"@type":"ImageObject","@id":"https://liliputing.com/#logo","inLanguage":"en-US","url":"https://liliputing.com/wp-content/uploads/2018/07/LiliputingLogo320.png","width":320,"height":65,"caption":"Liliputing"},"image":{"@id":"https://liliputing.com/#logo"}},{"@type":"WebSite","@id":"https://liliputing.com/#website","url":"https://liliputing.com/","name":"Liliputing","description":"","publisher":{"@id":"https://liliputing.com/#organization"},"potentialAction":[{"@type":"SearchAction","target":"https://liliputing.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://liliputing.com/2020/09/motorola-razr-2020-goes-on-sale-oct-2-for-1200.html#primaryimage","inLanguage":"en-US","url":"https://liliputing.com/wp-content/uploads/2020/09/razr-5g_07-1.jpg","width":1200,"height":1039},{"@type":"WebPage","@id":"https://liliputing.com/2020/09/motorola-razr-2020-goes-on-sale-oct-2-for-1200.html#webpage","url":"https://liliputing.com/2020/09/motorola-razr-2020-goes-on-sale-oct-2-for-1200.html","name":"Motorola Razr (2020) goes on sale Oct 2 for $1200 - Liliputing","isPartOf":{"@id":"https://liliputing.com/#website"},"primaryImageOfPage":{"@id":"https://liliputing.com/2020/09/motorola-razr-2020-goes-on-sale-oct-2-for-1200.html#primaryimage"},"datePublished":"2020-09-29T16:20:58+00:00","dateModified":"2020-09-29T16:20:58+00:00","description":"Motorola Razr (2020) goes on sale Oct 2 for $1200","inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://liliputing.com/2020/09/motorola-razr-2020-goes-on-sale-oct-2-for-1200.html"]}]},{"@type":"Article","@id":"https://liliputing.com/2020/09/motorola-razr-2020-goes-on-sale-oct-2-for-1200.html#article","isPartOf":{"@id":"https://liliputing.com/2020/09/motorola-razr-2020-goes-on-sale-oct-2-for-1200.html#webpage"},"author":{"@id":"https://liliputing.com/#/schema/person/5fa66014f13c5c75ee7a4cd424adc2da"},"headline":"Motorola Razr (2020) goes on sale Oct 2 for $1200","datePublished":"2020-09-29T16:20:58+00:00","dateModified":"2020-09-29T16:20:58+00:00","mainEntityOfPage":{"@id":"https://liliputing.com/2020/09/motorola-razr-2020-goes-on-sale-oct-2-for-1200.html#webpage"},"commentCount":0,"publisher":{"@id":"https://liliputing.com/#organization"},"image":{"@id":"https://liliputing.com/2020/09/motorola-razr-2020-goes-on-sale-oct-2-for-1200.html#primaryimage"},"keywords":"flip phone,foldable,motorola razr,razr","articleSection":"News","inLanguage":"en-US","potentialAction":[{"@type":"CommentAction","name":"Comment","target":["https://liliputing.com/2020/09/motorola-razr-2020-goes-on-sale-oct-2-for-1200.html#respond"]}]},{"@type":"Person","@id":"https://liliputing.com/#/schema/person/5fa66014f13c5c75ee7a4cd424adc2da","name":"Brad Linder","image":{"@type":"ImageObject","@id":"https://liliputing.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/bd56cb499bbc3cee3026c263d3bb5165?s=96&d=mm&r=g","caption":"Brad Linder"},"description":"Brad Linder is editor of Liliputing. He's been tinkering with mobile gadgets for decades and writing about them professionally since 2006. Brad has also worked with NPR, WHYY, PRI, and AOL's Download Squad.","sameAs":["https://twitter.com/bradlinder"]}]}</script> <link rel=dns-prefetch href=//secure.gravatar.com><link rel=dns-prefetch href=//s.w.org><link rel=dns-prefetch href=//v0.wordpress.com><link rel=alternate type=application/rss+xml title="Liliputing &raquo; Feed" href=https://liliputing.com/feed><link rel=alternate type=application/rss+xml title="Liliputing &raquo; Comments Feed" href=https://liliputing.com/comments/feed><link rel=alternate type=application/rss+xml title="Liliputing &raquo; Motorola Razr (2020) goes on sale Oct 2 for $1200 Comments Feed" href=https://liliputing.com/2020/09/motorola-razr-2020-goes-on-sale-oct-2-for-1200.html/feed> <script>window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/liliputing.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.5.1"}};
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);</script> <link rel=https://api.w.org/ href=https://liliputing.com/wp-json/><link rel=alternate type=application/json href=https://liliputing.com/wp-json/wp/v2/posts/135364><link rel=EditURI type=application/rsd+xml title=RSD href=https://liliputing.com/xmlrpc.php?rsd><link rel=wlwmanifest type=application/wlwmanifest+xml href=https://liliputing.com/wp-includes/wlwmanifest.xml><meta name=generator content="WordPress 5.5.1"><link rel=shortlink href='https://liliputing.com/?p=135364'><link rel=alternate type=application/json+oembed href="https://liliputing.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fliliputing.com%2F2020%2F09%2Fmotorola-razr-2020-goes-on-sale-oct-2-for-1200.html"><link rel=alternate type=text/xml+oembed href="https://liliputing.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fliliputing.com%2F2020%2F09%2Fmotorola-razr-2020-goes-on-sale-oct-2-for-1200.html&#038;format=xml"><link rel=amphtml href=https://liliputing.com/2020/09/motorola-razr-2020-goes-on-sale-oct-2-for-1200.html?amp><link rel=icon href=https://liliputing.com/wp-content/uploads/2020/02/cropped-lp_icon_1024-e1582423214846-32x32.png sizes=32x32><link rel=icon href=https://liliputing.com/wp-content/uploads/2020/02/cropped-lp_icon_1024-e1582423214846-192x192.png sizes=192x192><link rel=apple-touch-icon href=https://liliputing.com/wp-content/uploads/2020/02/cropped-lp_icon_1024-e1582423214846-180x180.png><meta name=msapplication-TileImage content=https://liliputing.com/wp-content/uploads/2020/02/cropped-lp_icon_1024-e1582423214846-270x270.png><link rel=apple-touch-icon sizes=180x180 href=/apple-touch-icon.png><link rel=icon type=image/png sizes=32x32 href=/favicon-32x32.png><link rel=icon type=image/png sizes=16x16 href=/favicon-16x16.png><link rel=manifest href=/site.webmanifest><link rel=mask-icon href=/safari-pinned-tab.svg color=#5bbad5><meta name=msapplication-TileColor content=#da532c><meta name=theme-color content=#111111> <script async src="https://www.googletagmanager.com/gtag/js?id=UA-4642989-1"></script> <script>window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-4642989-1');</script> <script data-ad-client=ca-pub-2998039209070153 async src=https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js></script>  <script id=nsgpt data-channel=homepage src=//cdn.nsstatic.net/ns/liliputing.com.js async=true></script>  <script id=nsgpt data-channel=general src=//cdn.nsstatic.net/ns/liliputing.com.js async=true></script>  <script async=async src=https://www.googletagservices.com/tag/js/gpt.js></script> <script>var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];</script> <script>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</script> </head><body class="post-template-default single single-post postid-135364 single-format-standard wp-custom-logo wp-embed-responsive singular hide-site-tagline h-nsub h-sb h-ll h-sh has-sidebar single-featured-image-default categories-hidden"><aside id=mobile-sidebar-fallback class=mobile-sidebar>
<button class=mobile-menu-toggle>
<svg class=svg-icon width=20 height=20 aria-hidden=true role=img xmlns=http://www.w3.org/2000/svg viewBox="0 0 24 24"><path d="M19 6.41L17.59 5 12 10.59 6.41 5 5 6.41 10.59 12 5 17.59 6.41 19 12 13.41 17.59 19 19 17.59 13.41 12z" /><path d="M0 0h24v24H0z" fill=none /></svg> Close	</button><form role=search method=get class=search-form action=https://liliputing.com/>
<label for=search-form-1>
<span class=screen-reader-text>Search for:</span>
</label>
<input type=search id=search-form-1 class=search-field placeholder="Search &hellip;" value name=s>
<button type=submit class=search-submit>
<svg class=svg-icon width=28 height=28 aria-hidden=true role=img xmlns=http://www.w3.org/2000/svg viewBox="0 0 24 24"><path d="M15.5 14h-.79l-.28-.27C15.41 12.59 16 11.11 16 9.5 16 5.91 13.09 3 9.5 3S3 5.91 3 9.5 5.91 16 9.5 16c1.61 0 3.09-.59 4.23-1.57l.27.28v.79l5 4.99L20.49 19l-4.99-5zm-6 0C7.01 14 5 11.99 5 9.5S7.01 5 9.5 5 14 7.01 14 9.5 11.99 14 9.5 14z" /><path d="M0 0h24v24H0z" fill=none /></svg> <span class=screen-reader-text>
Search	</span>
</button></form><nav class="main-navigation nav1" aria-label="Top Menu" toolbar-target=site-navigation toolbar="(min-width: 767px)"><ul id=menu-nav class=main-menu><li id=menu-item-59018 class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-59018"><a href=https://liliputing.com/category/reviews>Reviews</a></li><li id=menu-item-44420 class="menu-item menu-item-type-custom menu-item-object-custom menu-item-44420"><a href=https://liliputing.com/category/deals>Deals</a></li><li id=menu-item-83728 class="menu-item menu-item-type-custom menu-item-object-custom menu-item-83728"><a rel=nofollow href=https://liliputing.com/category/tutorials>How To&#8230;</a></li><li id=menu-item-44423 class="menu-item menu-item-type-custom menu-item-object-custom menu-item-44423"><a href=https://liliputing.com/tag/mini-pc>Mini PCs</a></li><li id=menu-item-134525 class="menu-item menu-item-type-custom menu-item-object-custom menu-item-134525"><a target=_blank rel=nofollow href=https://linuxsmartphones.com/>Linux Smartphones</a></li><li id=menu-item-66650 class="menu-item menu-item-type-custom menu-item-object-custom menu-item-66650"><a target=_blank rel=nofollow href="https://www.amazon.com/Best-Sellers-Computers-Accessories/zgbs/pc/ref=as_li_ss_tl?_encoding=UTF8&#038;linkCode=ll2&#038;tag=liliputing_shop-20&#038;linkId=93aaf7ba4e36ed56d46003558471548d">Shop</a></li><li id=menu-item-72206 class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-72206"><a aria-haspopup=true aria-expanded=false>About</a><button class=submenu-expand tabindex=-1><svg class=svg-icon width=24 height=24 aria-hidden=true role=img focusable=false xmlns=http://www.w3.org/2000/svg viewBox="0 0 24 24"><path d="M7.41 8.59L12 13.17l4.59-4.58L18 10l-6 6-6-6 1.41-1.41z"></path><path fill=none d="M0 0h24v24H0V0z"></path></svg></button><ul class=sub-menu><li id=menu-item-72208 class="menu-item menu-item-type-custom menu-item-object-custom menu-item-72208"><a href=https://liliputing.com/about>About Liliputing</a></li><li id=menu-item-44422 class="menu-item menu-item-type-custom menu-item-object-custom menu-item-44422"><a href=https://liliputing.com/contact>Contact us</a></li><li id=menu-item-72207 class="menu-item menu-item-type-custom menu-item-object-custom menu-item-72207"><a href=https://liliputing.com/advertise-on-liliputing>Advertise</a></li><li id=menu-item-104652 class="menu-item menu-item-type-post_type menu-item-object-page menu-item-104652"><a href=https://liliputing.com/support-liliputing>Support Liliputing</a></li><li id=menu-item-72209 class="menu-item menu-item-type-custom menu-item-object-custom menu-item-72209"><a href=https://liliputing.com/privacy-policy>Privacy Policy</a></li></ul></li></ul></nav></aside><aside id=desktop-sidebar-fallback class=desktop-sidebar>
<button class=desktop-menu-toggle>
<svg class=svg-icon width=20 height=20 aria-hidden=true role=img xmlns=http://www.w3.org/2000/svg viewBox="0 0 24 24"><path d="M19 6.41L17.59 5 12 10.59 6.41 5 5 6.41 10.59 12 5 17.59 6.41 19 12 13.41 17.59 19 19 17.59 13.41 12z" /><path d="M0 0h24v24H0z" fill=none /></svg> Close	</button></aside><div id=page class=site>
<a class="skip-link screen-reader-text" href=#content>Skip to content</a><header id=masthead class="site-header hide-header-search" [class]="searchVisible ? 'show-header-search site-header ' : 'hide-header-search site-header'"><div class=middle-header-contain><div class=wrapper><div class=site-branding><a href=https://liliputing.com/ class=custom-logo-link rel=home><img width=320 height=65 src=https://liliputing.com/wp-content/uploads/2018/07/LiliputingLogo320.png class=custom-logo alt=Liliputing srcset="https://liliputing.com/wp-content/uploads/2018/07/LiliputingLogo320.png 320w, https://liliputing.com/wp-content/uploads/2018/07/LiliputingLogo320-125x25.png 125w, https://liliputing.com/wp-content/uploads/2018/07/LiliputingLogo320-250x51.png 250w, https://liliputing.com/wp-content/uploads/2018/07/LiliputingLogo320-200x41.png 200w, https://liliputing.com/wp-content/uploads/2018/07/LiliputingLogo320-150x30.png 150w" sizes="(max-width: 320px) 100vw, 320px" data-attachment-id=110279 data-permalink=https://liliputing.com/liliputinglogo320 data-orig-file=https://liliputing.com/wp-content/uploads/2018/07/LiliputingLogo320.png data-orig-size=320,65 data-comments-opened=1 data-image-meta={&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;} data-image-title=LiliputingLogo320 data-image-description data-medium-file=https://liliputing.com/wp-content/uploads/2018/07/LiliputingLogo320-250x51.png data-large-file=https://liliputing.com/wp-content/uploads/2018/07/LiliputingLogo320.png></a><div class=site-identity><p class=site-title><a href=https://liliputing.com/ rel=home>Liliputing</a></p></div></div><div class="nav-wrapper desktop-only"><div id=site-navigation><nav class="main-navigation nav1" aria-label="Top Menu" toolbar-target=site-navigation toolbar="(min-width: 767px)"><ul id=menu-nav-1 class=main-menu><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-59018"><a href=https://liliputing.com/category/reviews>Reviews</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-44420"><a href=https://liliputing.com/category/deals>Deals</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-83728"><a rel=nofollow href=https://liliputing.com/category/tutorials>How To&#8230;</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-44423"><a href=https://liliputing.com/tag/mini-pc>Mini PCs</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-134525"><a target=_blank rel=nofollow href=https://linuxsmartphones.com/>Linux Smartphones</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-66650"><a target=_blank rel=nofollow href="https://www.amazon.com/Best-Sellers-Computers-Accessories/zgbs/pc/ref=as_li_ss_tl?_encoding=UTF8&#038;linkCode=ll2&#038;tag=liliputing_shop-20&#038;linkId=93aaf7ba4e36ed56d46003558471548d">Shop</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-72206"><a aria-haspopup=true aria-expanded=false>About</a><button class=submenu-expand tabindex=-1><svg class=svg-icon width=24 height=24 aria-hidden=true role=img focusable=false xmlns=http://www.w3.org/2000/svg viewBox="0 0 24 24"><path d="M7.41 8.59L12 13.17l4.59-4.58L18 10l-6 6-6-6 1.41-1.41z"></path><path fill=none d="M0 0h24v24H0V0z"></path></svg></button><ul class=sub-menu><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-72208"><a href=https://liliputing.com/about>About Liliputing</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-44422"><a href=https://liliputing.com/contact>Contact us</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-72207"><a href=https://liliputing.com/advertise-on-liliputing>Advertise</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-104652"><a href=https://liliputing.com/support-liliputing>Support Liliputing</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-72209"><a href=https://liliputing.com/privacy-policy>Privacy Policy</a></li></ul></li></ul></nav></div></div><div class="nav-wrapper desktop-only"><div id=tertiary-nav-contain></div><div class=header-search-contain>
<button id=search-toggle on="tap:AMP.setState( { searchVisible: !searchVisible } ), search-form-2.focus" aria-controls=search-menu [aria-expanded]="searchVisible ? 'true' : 'false'" aria-expanded=false>
<span class=screen-reader-text [text]="searchVisible ? 'Close Search' : 'Open Search'">
Open Search	</span>
<span class=search-icon><svg class=svg-icon width=28 height=28 aria-hidden=true role=img xmlns=http://www.w3.org/2000/svg viewBox="0 0 24 24"><path d="M15.5 14h-.79l-.28-.27C15.41 12.59 16 11.11 16 9.5 16 5.91 13.09 3 9.5 3S3 5.91 3 9.5 5.91 16 9.5 16c1.61 0 3.09-.59 4.23-1.57l.27.28v.79l5 4.99L20.49 19l-4.99-5zm-6 0C7.01 14 5 11.99 5 9.5S7.01 5 9.5 5 14 7.01 14 9.5 11.99 14 9.5 14z" /><path d="M0 0h24v24H0z" fill=none /></svg></span>
<span class=close-icon><svg class=svg-icon width=28 height=28 aria-hidden=true role=img xmlns=http://www.w3.org/2000/svg viewBox="0 0 24 24"><path d="M19 6.41L17.59 5 12 10.59 6.41 5 5 6.41 10.59 12 5 17.59 6.41 19 12 13.41 17.59 19 19 17.59 13.41 12z" /><path d="M0 0h24v24H0z" fill=none /></svg></span>
</button><div id=header-search [aria-expanded]="searchVisible ? 'true' : 'false'" aria-expanded=false><form role=search method=get class=search-form action=https://liliputing.com/>
<label for=search-form-2>
<span class=screen-reader-text>Search for:</span>
</label>
<input type=search id=search-form-2 class=search-field placeholder="Search &hellip;" value name=s>
<button type=submit class=search-submit>
<svg class=svg-icon width=28 height=28 aria-hidden=true role=img xmlns=http://www.w3.org/2000/svg viewBox="0 0 24 24"><path d="M15.5 14h-.79l-.28-.27C15.41 12.59 16 11.11 16 9.5 16 5.91 13.09 3 9.5 3S3 5.91 3 9.5 5.91 16 9.5 16c1.61 0 3.09-.59 4.23-1.57l.27.28v.79l5 4.99L20.49 19l-4.99-5zm-6 0C7.01 14 5 11.99 5 9.5S7.01 5 9.5 5 14 7.01 14 9.5 11.99 14 9.5 14z" /><path d="M0 0h24v24H0z" fill=none /></svg> <span class=screen-reader-text>
Search	</span>
</button></form></div></div></div><button class=mobile-menu-toggle on=tap:mobile-sidebar.toggle>
<svg class=svg-icon width=20 height=20 aria-hidden=true role=img xmlns=http://www.w3.org/2000/svg viewBox="0 0 24 24"><path d="M0 0h24v24H0z" fill=none /><path d="M3 18h18v-2H3v2zm0-5h18v-2H3v2zm0-7v2h18V6H3z" /></svg> Menu	</button></div></div><div id=header-widget-area class="hw-widget widget-area" role=complementary><div class=hw-widget><div class='code-block code-block-1' style='margin: 8px auto; text-align: center; display: block; clear: both;'><div data-ns=billboard></div></div></div></div></header><div id=content class=site-content><section id=primary class="content-area category-news tag-flip-phone tag-foldable tag-motorola-razr tag-razr"><main id=main class=site-main><header class=entry-header><span class=cat-links><span class=screen-reader-text>Posted in</span><a href=https://liliputing.com/category/news rel="category tag">News</a></span><h1 class="entry-title ">
Motorola Razr (2020) goes on sale Oct 2 for $1200</h1><div class=entry-subhead><div class=entry-meta>
<span class=author-avatar><img alt src='https://secure.gravatar.com/avatar/bd56cb499bbc3cee3026c263d3bb5165?s=96&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/bd56cb499bbc3cee3026c263d3bb5165?s=192&#038;d=mm&#038;r=g 2x' class='avatar avatar-96 photo' height=96 width=96 loading=lazy></span><span class=byline><span>by</span> <span class="author vcard"><a class="url fn n" href=https://liliputing.com/author/admin>Brad Linder</a></span></span><p>Posted on September 29, 2020 at 12:20 pm</p></div>
<a href=https://liliputing.com/2020/09/motorola-razr-2020-goes-on-sale-oct-2-for-1200.html#respond>No Comments<span class=screen-reader-text> on Motorola Razr (2020) goes on sale Oct 2 for $1200</span></a></div></header><div class=main-content><article id=post-135364 class="post-135364 post type-post status-publish format-standard has-post-thumbnail hentry category-news tag-flip-phone tag-foldable tag-motorola-razr tag-razr entry"><div class=entry-content><p>The new <a href=https://fave.co/32fAT3q rel=nofollow><strong>Motorola Razr (2020) smartphone</strong></a> is basically a modern flip phone with a foldable OLED display, a second screen on the cover, and better specs than the 2019 model at a slightly lower price.</p><p>When Motorola first announced the new phone earlier this month the company said it would be available this fall for $1400.</p><p>Now the company says you&#8217;ll be able to pick one up starting Oct 2 for $1200.</p><p><img data-attachment-id=135367 data-permalink=https://liliputing.com/2020/09/motorola-razr-2020-goes-on-sale-oct-2-for-1200.html/razr-5g_07-2 data-orig-file=https://liliputing.com/wp-content/uploads/2020/09/razr-5g_07-1.jpg data-orig-size=1200,1039 data-comments-opened=1 data-image-meta={&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;} data-image-title="razr 5g_07" data-image-description data-medium-file=https://liliputing.com/wp-content/uploads/2020/09/razr-5g_07-1-400x346.jpg data-large-file=https://liliputing.com/wp-content/uploads/2020/09/razr-5g_07-1-577x500.jpg loading=lazy class="aligncenter size-large wp-image-135367" src=https://liliputing.com/wp-content/uploads/2020/09/razr-5g_07-1-577x500.jpg alt width=577 height=500 srcset="https://liliputing.com/wp-content/uploads/2020/09/razr-5g_07-1-577x500.jpg 577w, https://liliputing.com/wp-content/uploads/2020/09/razr-5g_07-1-400x346.jpg 400w, https://liliputing.com/wp-content/uploads/2020/09/razr-5g_07-1-150x130.jpg 150w, https://liliputing.com/wp-content/uploads/2020/09/razr-5g_07-1-768x665.jpg 768w, https://liliputing.com/wp-content/uploads/2020/09/razr-5g_07-1.jpg 1200w" sizes="(max-width: 577px) 100vw, 577px"><div class='code-block code-block-4' style='margin: 8px auto; text-align: center; display: block; clear: both;'> <script async src=https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js></script>
<ins class=adsbygoogle style=display:block data-ad-client=ca-pub-2998039209070153 data-ad-slot=5402913141 data-ad-format=auto data-full-width-responsive=true></ins> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script></div></p><p>That price includes a $200 discount that will only be available for a limited time though, so at some point this thing may still sell for $1400, making it one of the most expensive smartphones to feature a Qualcomm Snapdragon 765G processor.</p><p>But while the CPU may be mid-range, the phone&#8217;s unusual design is the star of the show. The Motorola Razr has a 6.2inch, 2142 x 876 pixel pOLED display that can fold in half, allowing the phone to take up less space in your bag or pocket.</p><p>Since there&#8217;s a 2.7 inch, 800 x 600 pixel cover screen, you can also view notifications without flipping the phone open. Is that worth spending more than twice as much money on this phone as you&#8217;d spend if you opted for the latest OnePlus, Google Pixel, or Nokia phone? I suspect that&#8217;s a question only you can answer.</p><div data-carousel-extra='{"blog_id":1,"permalink":"https:\/\/liliputing.com\/2020\/09\/motorola-razr-2020-goes-on-sale-oct-2-for-1200.html"}' id=gallery-1 class='gallery galleryid-135364 gallery-columns-3 gallery-size-thumbnail'><figure class=gallery-item><div class='gallery-icon landscape'>
<a href=https://liliputing.com/2020/09/motorolas-new-razr-is-a-foldable-5g-flip-phone-coming-this-fall-for-1400.html/razr-5g_08><img width=150 height=89 src=https://liliputing.com/wp-content/uploads/2020/09/razr-5g_08-150x89.jpg class="attachment-thumbnail size-thumbnail" alt="Motorola Razr (2nd-gen)" loading=lazy srcset="https://liliputing.com/wp-content/uploads/2020/09/razr-5g_08-150x89.jpg 150w, https://liliputing.com/wp-content/uploads/2020/09/razr-5g_08-400x237.jpg 400w, https://liliputing.com/wp-content/uploads/2020/09/razr-5g_08-700x415.jpg 700w, https://liliputing.com/wp-content/uploads/2020/09/razr-5g_08-768x455.jpg 768w, https://liliputing.com/wp-content/uploads/2020/09/razr-5g_08.jpg 1174w" sizes="(max-width: 150px) 100vw, 150px" data-attachment-id=134474 data-permalink=https://liliputing.com/2020/09/motorolas-new-razr-is-a-foldable-5g-flip-phone-coming-this-fall-for-1400.html/razr-5g_08 data-orig-file=https://liliputing.com/wp-content/uploads/2020/09/razr-5g_08.jpg data-orig-size=1174,696 data-comments-opened=1 data-image-meta={&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;} data-image-title="razr 5g_08" data-image-description data-medium-file=https://liliputing.com/wp-content/uploads/2020/09/razr-5g_08-400x237.jpg data-large-file=https://liliputing.com/wp-content/uploads/2020/09/razr-5g_08-700x415.jpg></a></div></figure><figure class=gallery-item><div class='gallery-icon portrait'>
<a href=https://liliputing.com/2020/09/motorolas-new-razr-is-a-foldable-5g-flip-phone-coming-this-fall-for-1400.html/razr-5g_03><img width=140 height=150 src=https://liliputing.com/wp-content/uploads/2020/09/razr-5g_03-140x150.jpg class="attachment-thumbnail size-thumbnail" alt="Motorola Razr 5G" loading=lazy srcset="https://liliputing.com/wp-content/uploads/2020/09/razr-5g_03-140x150.jpg 140w, https://liliputing.com/wp-content/uploads/2020/09/razr-5g_03-372x400.jpg 372w, https://liliputing.com/wp-content/uploads/2020/09/razr-5g_03-465x500.jpg 465w, https://liliputing.com/wp-content/uploads/2020/09/razr-5g_03-768x826.jpg 768w, https://liliputing.com/wp-content/uploads/2020/09/razr-5g_03.jpg 801w" sizes="(max-width: 140px) 100vw, 140px" data-attachment-id=134468 data-permalink=https://liliputing.com/2020/09/motorolas-new-razr-is-a-foldable-5g-flip-phone-coming-this-fall-for-1400.html/razr-5g_03 data-orig-file=https://liliputing.com/wp-content/uploads/2020/09/razr-5g_03.jpg data-orig-size=801,861 data-comments-opened=1 data-image-meta={&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;} data-image-title="razr 5g_03" data-image-description data-medium-file=https://liliputing.com/wp-content/uploads/2020/09/razr-5g_03-372x400.jpg data-large-file=https://liliputing.com/wp-content/uploads/2020/09/razr-5g_03-465x500.jpg></a></div></figure><figure class=gallery-item><div class='gallery-icon landscape'>
<a href=https://liliputing.com/2020/09/motorolas-new-razr-is-a-foldable-5g-flip-phone-coming-this-fall-for-1400.html/razr-5g_04><img width=150 height=103 src=https://liliputing.com/wp-content/uploads/2020/09/razr-5g_04-150x103.jpg class="attachment-thumbnail size-thumbnail" alt="Motorola Razr 5G" loading=lazy srcset="https://liliputing.com/wp-content/uploads/2020/09/razr-5g_04-150x103.jpg 150w, https://liliputing.com/wp-content/uploads/2020/09/razr-5g_04-400x275.jpg 400w, https://liliputing.com/wp-content/uploads/2020/09/razr-5g_04-700x481.jpg 700w, https://liliputing.com/wp-content/uploads/2020/09/razr-5g_04-768x527.jpg 768w, https://liliputing.com/wp-content/uploads/2020/09/razr-5g_04.jpg 919w" sizes="(max-width: 150px) 100vw, 150px" data-attachment-id=134467 data-permalink=https://liliputing.com/2020/09/motorolas-new-razr-is-a-foldable-5g-flip-phone-coming-this-fall-for-1400.html/razr-5g_04 data-orig-file=https://liliputing.com/wp-content/uploads/2020/09/razr-5g_04.jpg data-orig-size=919,631 data-comments-opened=1 data-image-meta={&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;} data-image-title="razr 5g_04" data-image-description data-medium-file=https://liliputing.com/wp-content/uploads/2020/09/razr-5g_04-400x275.jpg data-large-file=https://liliputing.com/wp-content/uploads/2020/09/razr-5g_04-700x481.jpg></a></div></figure></div><p>Other features include 8GB of RAM, 256GB of storage, a 48MP rear camera, a 20MP front camera, a USB 3.1 Type-C port, and a 2,800 mAh battery.</p><p>The phone supports 15-watt fast charging, WiFi 5, Bluetooth 5.1, 5G (sub-6 GHz and mmWave) and NFC and has a mono speaker, four microphones, but no headphone jack. It does come with a USB-C to 3.5mm audio adapter though.</p><p><em>via <a href=https://www.androidpolice.com/2020/09/29/the-new-motorola-razr-is-what-the-first-one-should-have-been/>Android Police</a></em></p><div class='code-block code-block-13' style='margin: 8px auto; text-align: center; display: block; clear: both;'><div data-ns=rectangle data-pos=btf></div></div><section id=text-391998769 class="below-content widget widget_text"><div class=textwidget><h4>Share this article:</h4><div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon-text sd-sharing"><h3 class="sd-title">Share this:</h3><div class=sd-content><ul><li class=share-facebook><a rel="nofollow noopener noreferrer" data-shared=sharing-facebook-135364 class="share-facebook sd-button share-icon" href="https://liliputing.com/2020/09/motorola-razr-2020-goes-on-sale-oct-2-for-1200.html?share=facebook" target=_blank title="Click to share on Facebook"><span>Facebook</span></a></li><li class=share-twitter><a rel="nofollow noopener noreferrer" data-shared=sharing-twitter-135364 class="share-twitter sd-button share-icon" href="https://liliputing.com/2020/09/motorola-razr-2020-goes-on-sale-oct-2-for-1200.html?share=twitter" target=_blank title="Click to share on Twitter"><span>Twitter</span></a></li><li class=share-reddit><a rel="nofollow noopener noreferrer" data-shared class="share-reddit sd-button share-icon" href="https://liliputing.com/2020/09/motorola-razr-2020-goes-on-sale-oct-2-for-1200.html?share=reddit" target=_blank title="Click to share on Reddit"><span>Reddit</span></a></li><li class=share-pocket><a rel="nofollow noopener noreferrer" data-shared class="share-pocket sd-button share-icon" href="https://liliputing.com/2020/09/motorola-razr-2020-goes-on-sale-oct-2-for-1200.html?share=pocket" target=_blank title="Click to share on Pocket"><span>Pocket</span></a></li><li class=share-tumblr><a rel="nofollow noopener noreferrer" data-shared class="share-tumblr sd-button share-icon" href="https://liliputing.com/2020/09/motorola-razr-2020-goes-on-sale-oct-2-for-1200.html?share=tumblr" target=_blank title="Click to share on Tumblr"><span>Tumblr</span></a></li><li class=share-pinterest><a rel="nofollow noopener noreferrer" data-shared=sharing-pinterest-135364 class="share-pinterest sd-button share-icon" href="https://liliputing.com/2020/09/motorola-razr-2020-goes-on-sale-oct-2-for-1200.html?share=pinterest" target=_blank title="Click to share on Pinterest"><span>Pinterest</span></a></li><li class=share-linkedin><a rel="nofollow noopener noreferrer" data-shared=sharing-linkedin-135364 class="share-linkedin sd-button share-icon" href="https://liliputing.com/2020/09/motorola-razr-2020-goes-on-sale-oct-2-for-1200.html?share=linkedin" target=_blank title="Click to share on LinkedIn"><span>LinkedIn</span></a></li><li class=share-email><a rel="nofollow noopener noreferrer" data-shared class="share-email sd-button share-icon" href="https://liliputing.com/2020/09/motorola-razr-2020-goes-on-sale-oct-2-for-1200.html?share=email" target=_blank title="Click to email this to a friend"><span>Email</span></a></li><li class=share-end></li></ul></div></div></div></div></section><section id=ai_widget-7 class="below-content widget ai_widget"><div class='code-block code-block-8' style='margin: 8px auto; text-align: center; display: block; clear: both;'> <script async src=https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js></script> <ins class=adsbygoogle style=display:block data-ad-format=autorelaxed data-ad-client=ca-pub-2998039209070153 data-ad-slot=8039085398></ins> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script> <script async src=https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js></script>
<ins class=adsbygoogle style=display:block data-ad-client=ca-pub-2998039209070153 data-ad-slot=2123460997 data-ad-format=auto data-full-width-responsive=true></ins> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script></div></section><section id=custom_html-9 class="widget_text below-content widget widget_custom_html"><h2 class="widget-title">Support Liliputing</h2><div class="textwidget custom-html-widget"><div class=support-box><p>Liliputing's primary sources of revenue are advertising and affiliate links (if you click the "Shop" button at the top of the page and buy something on Amazon, for example, we'll get a small commission).</p><p>But there are several ways you can support the site directly even if you're using an ad blocker and hate online shopping.</p><p><h3>Contribute to our <a href=https://www.patreon.com/bradlinder>Patreon campaign</a></h3></p><p>
<em>or...</em></p><p><h3>Contribute via <a href="https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=PTBQ9EKAYTZBS&source=url">PayPal</a></h3></p></div></div></section></div><footer class=entry-footer>
<span class=tags-links><span>Tagged: </span><a href=https://liliputing.com/tag/flip-phone rel=tag>flip phone</a><span class=sep>,&nbsp;</span><a href=https://liliputing.com/tag/foldable rel=tag>foldable</a><span class=sep>,&nbsp;</span><a href=https://liliputing.com/tag/motorola-razr rel=tag>motorola razr</a><span class=sep>,&nbsp;</span><a href=https://liliputing.com/tag/razr rel=tag>razr</a></span></footer></article><div id=comments class=comments-area><div class="comments-title-wrap no-responses"><h2 class="comments-title">
Leave a comment</h2></div><div id=respond class=comment-respond><h3 id="reply-title" class="comment-reply-title"> <small><a rel=nofollow id=cancel-comment-reply-link href=/2020/09/motorola-razr-2020-goes-on-sale-oct-2-for-1200.html#respond style=display:none;>Cancel reply</a></small></h3><form action=https://liliputing.com/wp-comments-post.php method=post id=commentform class=comment-form novalidate><p class=comment-notes><span id=email-notes>Your email address will not be published.</span> Required fields are marked <span class=required>*</span></p><p class=comment-form-comment><label for=comment>Comment</label><textarea id=comment name=comment cols=45 rows=5 maxlength=65525 required=required></textarea></p><p class=comment-form-author><label for=author>Name <span class=required>*</span></label> <input id=author name=author type=text value size=30 maxlength=245 required=required></p><p class=comment-form-email><label for=email>Email <span class=required>*</span></label> <input id=email name=email type=email value size=30 maxlength=100 aria-describedby=email-notes required=required></p><p class=comment-form-url><label for=url>Website</label> <input id=url name=url type=url value size=30 maxlength=200></p><p class=comment-form-cookies-consent><input id=wp-comment-cookies-consent name=wp-comment-cookies-consent type=checkbox value=yes> <label for=wp-comment-cookies-consent>Save my name, email, and website in this browser for the next time I comment.</label></p><p class=comment-subscription-form><input type=checkbox name=subscribe_comments id=subscribe_comments value=subscribe style="width: auto; -moz-appearance: checkbox; -webkit-appearance: checkbox;"> <label class=subscribe-label id=subscribe-label for=subscribe_comments>Notify me of follow-up comments by email.</label></p><p class=comment-subscription-form><input type=checkbox name=subscribe_blog id=subscribe_blog value=subscribe style="width: auto; -moz-appearance: checkbox; -webkit-appearance: checkbox;"> <label class=subscribe-label id=subscribe-blog-label for=subscribe_blog>Notify me of new posts by email.</label></p><p class=form-submit><input name=submit type=submit id=submit class=submit value="Post Comment"> <input type=hidden name=comment_post_ID value=135364 id=comment_post_ID>
<input type=hidden name=comment_parent id=comment_parent value=0></p><p style="display: none;"><input type=hidden id=akismet_comment_nonce name=akismet_comment_nonce value=d14d16bf77></p><p style="display: none;"><input type=hidden id=ak_js name=ak_js value=124></p></form></div><p class=akismet_comment_form_privacy_notice>This site uses Akismet to reduce spam. <a href=https://akismet.com/privacy/ target=_blank rel="nofollow noopener">Learn how your comment data is processed</a>.</p></div></div><aside id=secondary class=widget-area><section id=search-4 class="widget widget_search"><form role=search method=get class=search-form action=https://liliputing.com/>
<label for=search-form-3>
<span class=screen-reader-text>Search for:</span>
</label>
<input type=search id=search-form-3 class=search-field placeholder="Search &hellip;" value name=s>
<button type=submit class=search-submit>
<svg class=svg-icon width=28 height=28 aria-hidden=true role=img xmlns=http://www.w3.org/2000/svg viewBox="0 0 24 24"><path d="M15.5 14h-.79l-.28-.27C15.41 12.59 16 11.11 16 9.5 16 5.91 13.09 3 9.5 3S3 5.91 3 9.5 5.91 16 9.5 16c1.61 0 3.09-.59 4.23-1.57l.27.28v.79l5 4.99L20.49 19l-4.99-5zm-6 0C7.01 14 5 11.99 5 9.5S7.01 5 9.5 5 14 7.01 14 9.5 11.99 14 9.5 14z" /><path d="M0 0h24v24H0z" fill=none /></svg> <span class=screen-reader-text>
Search	</span>
</button></form></section><section id=custom_html-4 class="widget_text widget widget_custom_html"><h2 class="widget-title accent-header"><span>Follow</span></h2><div class="textwidget custom-html-widget"><div class=social-icons><a href=https://facebook.com/liliputing target=_blank rel="me noopener noreferrer"><img src=https://liliputing.com/wp-content/uploads/2020/03/facebook-icon-e1583534816571.png alt=Facebook></a>
<a href=https://twitter.com/liliputingnews target=_blank rel="me noopener noreferrer"><img src=https://liliputing.com/wp-content/uploads/2020/03/twitter-icon-e1583534797368.png alt=Twitter></a>
<a href=https://www.youtube.com/liliputing target=_blank rel="me noopener noreferrer"><img src=https://liliputing.com/wp-content/uploads/2020/03/youtube-icon-e1583534833645.png alt=YouTube></a>
<a href=https://liliputing.com/feed target=_blank rel="noopener noreferrer"><img src=https://liliputing.com/wp-content/uploads/2020/03/rss-icon-e1583534826300.png alt=RSS></a>
<a href="https://www.patreon.com/bradlinder?ty=h" target=_blank rel="noopener noreferrer"><img src=https://liliputing.com/wp-content/uploads/2020/03/patreon-icon-e1583534809524.png alt=Patreon></a></div></div></section><section id=ai_widget-2 class="widget ai_widget"><div class='code-block code-block-9' style='margin: 8px 0; clear: both;'><div data-ns=halfpage data-pos=“atf” data-collapse=true data-responsive=true></div></div></section><section id=feedzy_wp_widget-5 class="widget widget_feedzy_wp_widget"><h2 class="widget-title accent-header"><span>Featured Articles</span></h2><div class="feedzy-rss feedzy-ddbf0b171b72d5074abcac80e06d67d6"><ul><li style="padding: 15px 0 25px" class=rss_item><div class=rss_image style="width:150px; height:150px;"><a href=https://liliputing.com/2020/09/review-acer-swift-3-with-ryzen-7-4700u-is-a-650-laptop-that-punches-above-its-class.html target rel="nofollow noopener" title="Review: Acer Swift 3 with Ryzen 7 4700U is a $650 laptop that punches above its class" style="width:150px; height:150px;"><span class=fetched style="background-image:  url('https://liliputing.com/wp-content/uploads/2020/09/swift-3-front_01-400x277.jpg');" title="Review: Acer Swift 3 with Ryzen 7 4700U is a $650 laptop that punches above its class"></span><amp-img width=150 height=150 src=https://liliputing.com/wp-content/uploads/2020/09/swift-3-front_01-400x277.jpg></a></div><span class=title><a href=https://liliputing.com/2020/09/review-acer-swift-3-with-ryzen-7-4700u-is-a-650-laptop-that-punches-above-its-class.html target rel="nofollow noopener">Review: Acer Swift 3 with Ryzen 7 4700U is a $650 laptop that punches above its class</a></span><div class=rss_content style></div></li><li style="padding: 15px 0 25px" class=rss_item><div class=rss_image style="width:150px; height:150px;"><a href=https://liliputing.com/2020/09/differences-between-the-google-pixel-5-and-pixel-4a-5-leaks.html target rel="nofollow noopener" title="Google Pixel 4a, Pixel 4a 5G and Pixel 5 compared (updated)" style="width:150px; height:150px;"><span class=fetched style="background-image:  url('https://liliputing.com/wp-content/uploads/2020/09/pixel-5_006-400x382.jpg');" title="Google Pixel 4a, Pixel 4a 5G and Pixel 5 compared (updated)"></span><amp-img width=150 height=150 src=https://liliputing.com/wp-content/uploads/2020/09/pixel-5_006-400x382.jpg></a></div><span class=title><a href=https://liliputing.com/2020/09/differences-between-the-google-pixel-5-and-pixel-4a-5-leaks.html target rel="nofollow noopener">Google Pixel 4a, Pixel 4a 5G and Pixel 5 compared (updated)</a></span><div class=rss_content style></div></li><li style="padding: 15px 0 25px" class=rss_item><div class=rss_image style="width:150px; height:150px;"><a href=https://liliputing.com/2020/09/ublock-origin-how-to-hide-googles-script-blocking-warning-for-websites-using-funding-choices.html target rel="nofollow noopener" title="uBlock Origin: How to hide Google’s script blocking warning for websites using Funding Choices" style="width:150px; height:150px;"><span class=fetched style="background-image:  url('https://liliputing.com/wp-content/uploads/2020/09/ublock_02-400x324.jpg');" title="uBlock Origin: How to hide Google’s script blocking warning for websites using Funding Choices"></span><amp-img width=150 height=150 src=https://liliputing.com/wp-content/uploads/2020/09/ublock_02-400x324.jpg></a></div><span class=title><a href=https://liliputing.com/2020/09/ublock-origin-how-to-hide-googles-script-blocking-warning-for-websites-using-funding-choices.html target rel="nofollow noopener">uBlock Origin: How to hide Google’s script blocking warning for websites using Funding Choices</a></span><div class=rss_content style></div></li></ul></div></section><section id=feedzy_wp_widget-4 class="widget widget_feedzy_wp_widget"><h2 class="widget-title accent-header"><span>Latest Deals</span></h2><div class="feedzy-rss feedzy-40121fefbfb517f38fa17b52c4cff378"><ul><li style="padding: 15px 0 25px" class=rss_item><div class=rss_image style="width:150px; height:150px;"><a href=https://liliputing.com/2020/09/daily-deals-9-28-2020.html target rel="nofollow noopener" title="Daily Deals (9-28-2020)" style="width:150px; height:150px;"><span class=fetched style="background-image:  url('https://liliputing.com/wp-content/uploads/2020/09/prime-day-2020-400x339.jpg');" title="Daily Deals (9-28-2020)"></span><amp-img width=150 height=150 src=https://liliputing.com/wp-content/uploads/2020/09/prime-day-2020-400x339.jpg></a></div><span class=title><a href=https://liliputing.com/2020/09/daily-deals-9-28-2020.html target rel="nofollow noopener">Daily Deals (9-28-2020)</a></span><div class=rss_content style></div></li><li style="padding: 15px 0 25px" class=rss_item><div class=rss_image style="width:150px; height:150px;"><a href=https://liliputing.com/2020/09/daily-deals-9-25-2020.html target rel="nofollow noopener" title="Daily Deals (9-25-2020)" style="width:150px; height:150px;"><span class=fetched style="background-image:  url('https://liliputing.com/wp-content/uploads/2020/09/iconikal_02-400x269.jpg');" title="Daily Deals (9-25-2020)"></span><amp-img width=150 height=150 src=https://liliputing.com/wp-content/uploads/2020/09/iconikal_02-400x269.jpg></a></div><span class=title><a href=https://liliputing.com/2020/09/daily-deals-9-25-2020.html target rel="nofollow noopener">Daily Deals (9-25-2020)</a></span><div class=rss_content style></div></li></ul></div></section><section id=ai_widget-8 class="widget ai_widget"><div class='code-block code-block-15' style='margin: 8px auto; text-align: center; display: block; clear: both;'> <script>amzn_assoc_tracking_id = "lp_sidebar-20";
amzn_assoc_ad_mode = "manual";
amzn_assoc_ad_type = "smart";
amzn_assoc_marketplace = "amazon";
amzn_assoc_region = "US";
amzn_assoc_design = "enhanced_links";
amzn_assoc_asins = "B072MMH33F";
amzn_assoc_placement = "adunit";
amzn_assoc_linkid = "18e9d2c9911d5bcd4208077a1e81419d";</script> <script src="//z-na.amazon-adsystem.com/widgets/onejs?MarketPlace=US"></script> <script>amzn_assoc_tracking_id = "lp_sidebar-20";
amzn_assoc_ad_mode = "manual";
amzn_assoc_ad_type = "smart";
amzn_assoc_marketplace = "amazon";
amzn_assoc_region = "US";
amzn_assoc_design = "enhanced_links";
amzn_assoc_asins = "B0868WSTXH";
amzn_assoc_placement = "adunit";
amzn_assoc_linkid = "4c3244e05865f79ea8f932e151c9411b";</script> <script src="//z-na.amazon-adsystem.com/widgets/onejs?MarketPlace=US"></script></div></section><section id=text-391998742 class="widget widget_text"><div class=textwidget><em>Disclosure: Some links on this page are monetized by <a rel=nofollow href="https://go.skimlinks.com/?id=32X105&amp;xs=1&amp;url=https://skimlinks.com">Skimlinks</a> and <a rel=nofollow href=https://affiliate-program.amazon.com/welcome>Amazon's</a> and <a rel="no follow" href=https://partnernetwork.ebay.com/>eBay's</a> affiliate programs.</em></div></section><section id=ai_widget-4 class="widget ai_widget"><div class='code-block code-block-11' style='margin: 8px 0; clear: both;'> <script async src=https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js></script>
<ins class=adsbygoogle style=display:block data-ad-client=ca-pub-2998039209070153 data-ad-slot=6991454926 data-ad-format=auto data-full-width-responsive=true></ins> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script></div></section><section id=feedzy_wp_widget-3 class="widget widget_feedzy_wp_widget"><h2 class="widget-title accent-header"><span>Recent Posts</span></h2><div class="feedzy-rss feedzy-fa87c4692753453526c86b88b8b2c2d5"><ul><li style="padding: 15px 0 25px" class=rss_item><div class=rss_image style="width:150px; height:150px;"><a href=https://liliputing.com/2020/09/motorola-razr-2020-goes-on-sale-oct-2-for-1200.html target rel="nofollow noopener" title="Motorola Razr (2020) goes on sale Oct 2 for $1200" style="width:150px; height:150px;"><span class=fetched style="background-image:  url('https://liliputing.com/wp-content/uploads/2020/09/razr-5g_07-1-400x346.jpg');" title="Motorola Razr (2020) goes on sale Oct 2 for $1200"></span><amp-img width=150 height=150 src=https://liliputing.com/wp-content/uploads/2020/09/razr-5g_07-1-400x346.jpg></a></div><span class=title><a href=https://liliputing.com/2020/09/motorola-razr-2020-goes-on-sale-oct-2-for-1200.html target rel="nofollow noopener">Motorola Razr (2020) goes on sale Oct 2 for $1200</a></span><div class=rss_content style></div></li><li style="padding: 15px 0 25px" class=rss_item><div class=rss_image style="width:150px; height:150px;"><a href=https://liliputing.com/2020/09/2-pound-lenovo-thinkpad-x1-nano-laptop-coming-soon-for-1400-and-up.html target rel="nofollow noopener" title="2 pound Lenovo ThinkPad X1 Nano laptop coming soon for $1400 and up" style="width:150px; height:150px;"><span class=fetched style="background-image:  url('https://liliputing.com/wp-content/uploads/2020/09/lenovo-thinkpad-x1-nano_05-400x332.jpg');" title="2 pound Lenovo ThinkPad X1 Nano laptop coming soon for $1400 and up"></span><amp-img width=150 height=150 src=https://liliputing.com/wp-content/uploads/2020/09/lenovo-thinkpad-x1-nano_05-400x332.jpg></a></div><span class=title><a href=https://liliputing.com/2020/09/2-pound-lenovo-thinkpad-x1-nano-laptop-coming-soon-for-1400-and-up.html target rel="nofollow noopener">2 pound Lenovo ThinkPad X1 Nano laptop coming soon for $1400 and up</a></span><div class=rss_content style></div></li><li style="padding: 15px 0 25px" class=rss_item><div class=rss_image style="width:150px; height:150px;"><a href=https://liliputing.com/2020/09/7-7-x-5-5-x-1-7.html target rel="nofollow noopener" title="Gigabyte launches Brix mini PCs with 28W Intel Tiger Lake chips" style="width:150px; height:150px;"><span class=fetched style="background-image:  url('https://liliputing.com/wp-content/uploads/2020/09/brix-tiger_03-400x149.jpg');" title="Gigabyte launches Brix mini PCs with 28W Intel Tiger Lake chips"></span><amp-img width=150 height=150 src=https://liliputing.com/wp-content/uploads/2020/09/brix-tiger_03-400x149.jpg></a></div><span class=title><a href=https://liliputing.com/2020/09/7-7-x-5-5-x-1-7.html target rel="nofollow noopener">Gigabyte launches Brix mini PCs with 28W Intel Tiger Lake chips</a></span><div class=rss_content style></div></li></ul></div></section><section id=recent-comments-2 class="widget widget_recent_comments"><h2 class="widget-title accent-header"><span>Recent Comments</span></h2><ul id=recentcomments><li class=recentcomments><span class=comment-author-link>Generalheed</span> on <a href=https://liliputing.com/2020/09/7-7-x-5-5-x-1-7.html#comment-1156297>Gigabyte launches Brix mini PCs with 28W Intel Tiger Lake chips</a></li><li class=recentcomments><span class=comment-author-link><a href=https://www.liliputing.com rel='external nofollow ugc' class=url>Brad Linder</a></span> on <a href=https://liliputing.com/2020/09/review-acer-swift-3-with-ryzen-7-4700u-is-a-650-laptop-that-punches-above-its-class.html#comment-1156295>Review: Acer Swift 3 with Ryzen 7 4700U is a $650 laptop that punches above its class</a></li><li class=recentcomments><span class=comment-author-link>riddick</span> on <a href=https://liliputing.com/2020/09/7-7-x-5-5-x-1-7.html#comment-1156292>Gigabyte launches Brix mini PCs with 28W Intel Tiger Lake chips</a></li><li class=recentcomments><span class=comment-author-link>Ilvee</span> on <a href=https://liliputing.com/2020/09/7-7-x-5-5-x-1-7.html#comment-1156288>Gigabyte launches Brix mini PCs with 28W Intel Tiger Lake chips</a></li><li class=recentcomments><span class=comment-author-link>Lillian Charles</span> on <a href=https://liliputing.com/2020/09/review-acer-swift-3-with-ryzen-7-4700u-is-a-650-laptop-that-punches-above-its-class.html#comment-1156284>Review: Acer Swift 3 with Ryzen 7 4700U is a $650 laptop that punches above its class</a></li></ul></section><section id=feedzy_wp_widget-2 class="widget widget_feedzy_wp_widget"><h2 class="widget-title accent-header"><span>Latest from Linux Smartphones</span></h2><div class="feedzy-rss feedzy-b7fba5ebd88ef32c390c1a71aa692078"><ul><li style="padding: 15px 0 25px" class=rss_item><div class=rss_image style="width:150px; height:150px;"><a href=https://linuxsmartphones.com/volla-phone-set-to-ship-to-crowdfunding-backers-in-november/ target=_blank rel="nofollow noopener" title="Volla Phone set to ship to crowdfunding backers in November" style="width:150px; height:150px;"><span class=fetched style="background-image:  url('https://linuxsmartphones.com/wp-content/uploads/2020/09/volla-phone-400x256.jpg');" title="Volla Phone set to ship to crowdfunding backers in November"></span><amp-img width=150 height=150 src=https://linuxsmartphones.com/wp-content/uploads/2020/09/volla-phone-400x256.jpg></a></div><span class=title><a href=https://linuxsmartphones.com/volla-phone-set-to-ship-to-crowdfunding-backers-in-november/ target=_blank rel="nofollow noopener">Volla Phone set to ship to crowdfunding backers in November</a></span><div class=rss_content style></div></li><li style="padding: 15px 0 25px" class=rss_item><div class=rss_image style="width:150px; height:150px;"><a href=https://linuxsmartphones.com/pinephone-news-roundup-9-25-2020/ target=_blank rel="nofollow noopener" title="PinePhone news roundup (9-25-2020)" style="width:150px; height:150px;"><span class=fetched style="background-image:  url('https://linuxsmartphones.com/wp-content/uploads/2020/09/megapixels-400x267.jpg');" title="PinePhone news roundup (9-25-2020)"></span><amp-img width=150 height=150 src=https://linuxsmartphones.com/wp-content/uploads/2020/09/megapixels-400x267.jpg></a></div><span class=title><a href=https://linuxsmartphones.com/pinephone-news-roundup-9-25-2020/ target=_blank rel="nofollow noopener">PinePhone news roundup (9-25-2020)</a></span><div class=rss_content style></div></li><li style="padding: 15px 0 25px" class=rss_item><div class=rss_image style="width:150px; height:150px;"><a href=https://linuxsmartphones.com/ubuntu-touch-ota-13-released-with-browser-improvements-new-features-support-for-more-phones/ target=_blank rel="nofollow noopener" title="Ubuntu Touch OTA-13 released with browser improvements, new features, support for more phones" style="width:150px; height:150px;"><span class=fetched style="background-image:  url('https://linuxsmartphones.com/wp-content/uploads/2020/09/ubuntu-touch-ota-13-400x231.jpg');" title="Ubuntu Touch OTA-13 released with browser improvements, new features, support for more phones"></span><amp-img width=150 height=150 src=https://linuxsmartphones.com/wp-content/uploads/2020/09/ubuntu-touch-ota-13-400x231.jpg></a></div><span class=title><a href=https://linuxsmartphones.com/ubuntu-touch-ota-13-released-with-browser-improvements-new-features-support-for-more-phones/ target=_blank rel="nofollow noopener">Ubuntu Touch OTA-13 released with browser improvements, new features, support for more phones</a></span><div class=rss_content style></div></li></ul></div></section><section id=ai_widget-3 class="widget ai_widget"><div class='code-block code-block-10' style='margin: 8px 0; clear: both;'><div data-ns=halfpage data-pos=“btf” data-collapse=true data-responsive=true></div></div></section></aside></main></section></div><footer id=colophon class=site-footer><div class=site-info><div class="wrapper site-info-contain">
<span class=copyright>&copy; 2020 Liliputing.</span>
<a class=privacy-policy-link href=https://liliputing.com/privacy-policy>Privacy Policy</a></div></div></footer></div><div style=display:none><div class=grofile-hash-map-bd56cb499bbc3cee3026c263d3bb5165></div></div> <script>window.WPCOM_sharing_counts = {"https:\/\/liliputing.com\/2020\/09\/motorola-razr-2020-goes-on-sale-oct-2-for-1200.html":135364};</script> <div id=sharing_email style="display: none;"><form action=/2020/09/motorola-razr-2020-goes-on-sale-oct-2-for-1200.html method=post>
<label for=target_email>Send to Email Address</label>
<input type=email name=target_email id=target_email value>
<label for=source_name>Your Name</label>
<input type=text name=source_name id=source_name value><label for=source_email>Your Email Address</label>
<input type=email name=source_email id=source_email value><input type=text id=jetpack-source_f_name name=source_f_name class=input value size=25 autocomplete=off title="This field is for validation and should not be changed">
<img style="float: right; display: none" class=loading src=https://liliputing.com/wp-content/plugins/jetpack/modules/sharedaddy/images/loading.gif alt=loading width=16 height=16>
<input type=submit value="Send Email" class=sharing_send>
<a rel=nofollow href=#cancel class=sharing_cancel role=button>Cancel</a><div class="errors errors-1" style="display: none;">
Post was not sent - check your email addresses!</div><div class="errors errors-2" style="display: none;">
Email check failed, please try again</div><div class="errors errors-3" style="display: none;">
Sorry, your blog cannot share posts by email.</div></form></div> <script src='https://secure.gravatar.com/js/gprofiles.js?ver=202040' id=grofiles-cards-js></script> <script id=wpgroho-js-extra>var WPGroHo = {"my_hash":""};</script> <script id=newspack-amp-fallback-js-extra>var newspackScreenReaderText = {"open_search":"Open Search","close_search":"Close Search","expand_comments":"Expand Comments","collapse_comments":"Collapse Comments","show_order_details":"Show details","hide_order_details":"Hide details"};</script> <script src='https://liliputing.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp' id=jquery-core-js></script> <script id=jetpack-carousel-js-extra>var jetpackCarouselStrings = {"widths":[370,700,1000,1200,1400,2000],"is_logged_in":"","lang":"en","ajaxurl":"https:\/\/liliputing.com\/wp-admin\/admin-ajax.php","nonce":"8e2a506ed3","display_exif":"0","display_comments":"0","display_geo":"1","single_image_gallery":"1","single_image_gallery_media_file":"","background_color":"black","comment":"Comment","post_comment":"Post Comment","write_comment":"Write a Comment...","loading_comments":"Loading Comments...","download_original":"View full size <span class=\"photo-size\">{0}<span class=\"photo-size-times\">\u00d7<\/span>{1}<\/span>","no_comment_text":"Please be sure to submit some text with your comment.","no_comment_email":"Please provide an email address to comment.","no_comment_author":"Please provide your name to comment.","comment_post_error":"Sorry, but there was an error posting your comment. Please try again later.","comment_approved":"Your comment was approved.","comment_unapproved":"Your comment is in moderation.","camera":"Camera","aperture":"Aperture","shutter_speed":"Shutter Speed","focal_length":"Focal Length","copyright":"Copyright","comment_registration":"0","require_name_email":"1","login_url":"https:\/\/liliputing.com\/wp-login.php?redirect_to=https%3A%2F%2Fliliputing.com%2F2020%2F09%2Fmotorola-razr-2020-goes-on-sale-oct-2-for-1200.html","blog_id":"1","meta_data":["camera","aperture","shutter_speed","focal_length","copyright"],"local_comments_commenting_as":"<fieldset><label for=\"email\">Email (Required)<\/label> <input type=\"text\" name=\"email\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-email-field\" \/><\/fieldset><fieldset><label for=\"author\">Name (Required)<\/label> <input type=\"text\" name=\"author\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-author-field\" \/><\/fieldset><fieldset><label for=\"url\">Website<\/label> <input type=\"text\" name=\"url\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-url-field\" \/><\/fieldset>"};</script> <script id=sharing-js-js-extra>var sharing_js_options = {"lang":"en","counts":"1","is_stats_active":"1"};</script> <script id=sharing-js-js-after>var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-facebook', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-twitter', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-pocket', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcompocket', 'menubar=1,resizable=1,width=450,height=450' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-tumblr', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtumblr', 'menubar=1,resizable=1,width=450,height=450' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-linkedin', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomlinkedin', 'menubar=1,resizable=1,width=580,height=450' );
				return false;
			});</script> <script>/(trident|msie)/i.test(navigator.userAgent)&&document.getElementById&&window.addEventListener&&window.addEventListener("hashchange",function(){var t,e=location.hash.substring(1);/^[A-z0-9_-]+$/.test(e)&&(t=document.getElementById(e))&&(/^(?:a|select|input|button|textarea)$/i.test(t.tagName)||(t.tabIndex=-1),t.focus())},!1);</script> <script src=https://stats.wp.com/e-202040.js async=async defer=defer></script> <script>_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:8.9.1',blog:'4896475',post:'135364',tz:'-4',srv:'liliputing.com'} ]);
	_stq.push([ 'clickTrackerInit', '4896475', '135364' ]);</script> <script>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</script> <script defer src=https://liliputing.com/wp-content/cache/autoptimize/autoptimize_fe49018cf334b3cd7382f3ecf2832104.php></script></body></html>
