<!DOCTYPE html>
<html lang="en-US" prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb#">
<head >
<meta charset="UTF-8" />
<title>Android O imminent after Google releases Dev Preview 4 - Liliputing</title><meta name="viewport" content="width=device-width, initial-scale=1" />

<!-- This site is optimized with the Yoast SEO plugin v5.0.2 - https://yoast.com/wordpress/plugins/seo/ -->
<link rel="canonical" href="https://liliputing.com/2017/07/android-o-imminent-google-releases-dev-preview-4.html" />
<link rel="publisher" href="https://plus.google.com/Liliputing"/>
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Android O imminent after Google releases Dev Preview 4 - Liliputing" />
<meta property="og:description" content="Eager to get your hands on Android O, but not so excited about flashing a beta OS on your devices? You may not have to wait much longer for the next major Android release to drop. It could be happening in just a couple of weeks. Google announced today on the Android Developers blog that &hellip;" />
<meta property="og:url" content="https://liliputing.com/2017/07/android-o-imminent-google-releases-dev-preview-4.html" />
<meta property="og:site_name" content="Liliputing" />
<meta property="article:publisher" content="https://www.facebook.com/Liliputing" />
<meta property="article:tag" content="android" />
<meta property="article:tag" content="android o" />
<meta property="article:tag" content="google" />
<meta property="article:tag" content="operating systems" />
<meta property="article:section" content="news" />
<meta property="article:published_time" content="2017-07-24T16:00:07-04:00" />
<meta property="article:modified_time" content="2017-07-24T16:46:48-04:00" />
<meta property="og:updated_time" content="2017-07-24T16:46:48-04:00" />
<meta property="fb:admins" content="648557080" />
<meta property="og:image" content="https://liliputing.com/wp-content/uploads/2017/07/android-o.jpg" />
<meta property="og:image:width" content="680" />
<meta property="og:image:height" content="524" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:description" content="Eager to get your hands on Android O, but not so excited about flashing a beta OS on your devices? You may not have to wait much longer for the next major Android release to drop. It could be happening in just a couple of weeks. Google announced today on the Android Developers blog that [&hellip;]" />
<meta name="twitter:title" content="Android O imminent after Google releases Dev Preview 4 - Liliputing" />
<meta name="twitter:site" content="@liliputingnews" />
<meta name="twitter:image" content="https://i2.wp.com/liliputing.com/wp-content/uploads/2017/07/android-o.jpg?fit=680%2C524&#038;ssl=1" />
<meta name="twitter:creator" content="@liliputingnews" />
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//www.google.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Liliputing &raquo; Feed" href="http://feeds.feedburner.com/Liliputing" />
<link rel="alternate" type="application/rss+xml" title="Liliputing &raquo; Comments Feed" href="https://liliputing.com/comments/feed" />
<link rel="alternate" type="application/rss+xml" title="Liliputing &raquo; Android O imminent after Google releases Dev Preview 4 Comments Feed" href="https://liliputing.com/2017/07/android-o-imminent-google-releases-dev-preview-4.html/feed" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/liliputing.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.8"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,56826,8203,55356,56819),0,0),c=j.toDataURL(),b===c&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55358,56794,8205,9794,65039),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55358,56794,8203,9794,65039),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='liliputingtheme-pro-theme-css'  href='https://liliputing-wpengine.netdna-ssl.com/wp-content/themes/LiliputingTheme/style.css?ver=2.0' type='text/css' media='all' />
<link rel='stylesheet' id='SFSImainCss-css'  href='https://liliputing-wpengine.netdna-ssl.com/wp-content/plugins/ultimate-social-media-icons/css/sfsi-style.css?ver=4.8' type='text/css' media='all' />
<link rel='stylesheet' id='wsl-widget-css'  href='https://liliputing-wpengine.netdna-ssl.com/wp-content/plugins/wordpress-social-login/assets/css/style.css?ver=4.8' type='text/css' media='all' />
<link rel='stylesheet' id='wpdiscuz-font-awesome-css'  href='https://liliputing-wpengine.netdna-ssl.com/wp-content/plugins/wpdiscuz/assets/third-party/font-awesome-4.6.3/css/font-awesome.min.css?ver=4.5.0' type='text/css' media='all' />
<link rel='stylesheet' id='wpdiscuz-frontend-css-css'  href='https://liliputing-wpengine.netdna-ssl.com/wp-content/plugins/wpdiscuz/assets/css/wpdiscuz.css?ver=4.0.8' type='text/css' media='all' />
<link rel='stylesheet' id='wpdiscuz-recaptcha-css-css'  href='https://liliputing-wpengine.netdna-ssl.com/wp-content/plugins/wpdiscuz-recaptcha/css/wpdiscuz-recaptcha.css?ver=1.0.7' type='text/css' media='all' />
<link rel='stylesheet' id='wpdiscuz-flag-css-css'  href='https://liliputing-wpengine.netdna-ssl.com/wp-content/plugins/wpdiscuz-report-flagging/resources/css/flag.css?ver=1.1.7' type='text/css' media='all' />
<link rel='stylesheet' id='wam-frontend-css-css'  href='https://liliputing-wpengine.netdna-ssl.com/wp-content/plugins/wpdiscuz-ads-manager/assets/css/frontend.css?ver=1.0.4' type='text/css' media='all' />
<link rel='stylesheet' id='an_style-css'  href='https://liliputing-wpengine.netdna-ssl.com/wp-content/uploads/cNKqedQunDmp/QrSHFhljcLbE.css?ver=2.2.1' type='text/css' media='all' />
<style id='an_style-inline-css' type='text/css'>
/*	an_style.css	AdBlock Notify	Copyright: (c) 2016 Themeisle, themeisle.com	Version: 2.1.0*/.ETAQBCZDpJUu-bg {	display: none;	position: fixed;	z-index: 100;	top: 0;	left: 0;	width: 100%;	height: 100%;	background: #000;	background: rgba(0,0,0,0.75);}.ETAQBCZDpJUu {	visibility: hidden;	position: fixed;	z-index: 101;	top: 100px;	right: 0;	left: 0;	max-width: 640px;	margin-right: auto;	margin-left: auto;	background: #fff;	-webkit-box-shadow: 0 3px 5px 2px rgba(0,0,0,0.25);	box-shadow: 0 3px 5px 2px rgba(0,0,0,0.25);	font-family: Arial, Helvetica, sans-serif;}.ETAQBCZDpJUu-default,.ETAQBCZDpJUu-ok {	padding: 30px 30px 15px;}.ETAQBCZDpJUu-image {	overflow: hidden;	position: relative;	width: 100%;}.ETAQBCZDpJUu-image .ETAQBCZDpJUu-left {	position: absolute;	top: 0;	left: 0;	width: 50%;	height: 100%;}.ETAQBCZDpJUu-image .ETAQBCZDpJUu-right {	float: right;	width: 50%;	padding: 30px;}.ETAQBCZDpJUu.small {	width: 200px;	margin-left: -140px;}.ETAQBCZDpJUu.medium {	width: 400px;	margin-left: -240px;}.ETAQBCZDpJUu.large {	width: 600px;	margin-left: -340px;}.ETAQBCZDpJUu.xlarge {	width: 800px;	margin-left: -440px;}.close-ETAQBCZDpJUu {	display: inline-block;	position: absolute;	top: 15px;	right: 15px;	width: 30px;	height: 30px;	color: #bbb;	font-size: 32px;	font-weight: 700;	line-height: 30px;	text-align: center;	cursor: pointer;	-webkit-transition: 0.3s;	transition: 0.3s;}.close-ETAQBCZDpJUu:hover {	color: #252b37;}.ETAQBCZDpJUu h1 {	margin-bottom: 15px;	padding: 0 30px;	color: #252b37;	font-size: 28px;	line-height: 1.25;	text-align: center;}.ETAQBCZDpJUu-right h1 {	padding: 0 30px 0 0;	text-align: left;}.ETAQBCZDpJUu p {	margin-bottom: 15px;	color: #333745;	font-size: 14px;}.ETAQBCZDpJUu p a {	color: #ff6160;}.ETAQBCZDpJUu-right .close-modal,.ETAQBCZDpJUu-footer .close-modal {	padding: 15px !important;	border-radius: 0 !important;	background-color: #ff6160;	font-size: 14px;	letter-spacing: 2px !important;	-webkit-transition: 0.3s;	transition: 0.3s;}.ETAQBCZDpJUu-right .close-modal:hover,.ETAQBCZDpJUu-footer .close-modal:hover {	background-color: #252b37 !important;}.ETAQBCZDpJUu-footer .grey-button-modal {	margin-right: 15px;	background-color: #a5a5a5;}.ETAQBCZDpJUu-footer {	display: block;	padding: 15px 30px;	background-color: #eff4f7;	text-align: right;}@media only screen and (max-width: 640px) {	.ETAQBCZDpJUu {		right: 5%;		left: 5%;		max-width: 90%;	}	.ETAQBCZDpJUu-default {		padding: 20px;	}	.ETAQBCZDpJUu-image .ETAQBCZDpJUu-left {		width: 100%;		height: 250px;	}	.ETAQBCZDpJUu-image .ETAQBCZDpJUu-right {		float: left;		width: 100%;		margin-top: 250px;		padding: 20px;	}	.ETAQBCZDpJUu h1 {		margin-bottom: 10px;		font-size: 20px;	}	.ETAQBCZDpJUu-right h1 {		padding: 0;	}	.ETAQBCZDpJUu p {		margin-bottom: 10px;	}	.close-ETAQBCZDpJUu {		color: #fcfcfc;		background-color: #252b37;	}	.close-ETAQBCZDpJUu:hover {		color: #252b37;		background-color: #fcfcfc;	}	.ETAQBCZDpJUu-footer {		padding: 15px 20px;	}}@media only screen and (max-width: 480px) {	.ETAQBCZDpJUu-image .ETAQBCZDpJUu-left {		height: 200px;	}	.ETAQBCZDpJUu-image .ETAQBCZDpJUu-right {		margin-top: 200px;	}	.ETAQBCZDpJUu-footer {		text-align: center;	}	.ETAQBCZDpJUu-footer .close-modal {		width: 80%;		margin: 5px 10%;	}}
</style>
<link rel='stylesheet' id='social-logos-css'  href='https://liliputing-wpengine.netdna-ssl.com/wp-content/plugins/jetpack/_inc/social-logos/social-logos.min.css?ver=1' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://liliputing-wpengine.netdna-ssl.com/wp-content/plugins/jetpack/css/jetpack.css?ver=5.1' type='text/css' media='all' />
<link rel='stylesheet' id='wpdiscuz-mod-moderation-styles-css'  href='https://liliputing-wpengine.netdna-ssl.com/wp-content/plugins/wpdiscuz-frontend-moderation/assets/css/style.css?ver=1.0.6' type='text/css' media='all' />
<script type='text/javascript' src='https://liliputing-wpengine.netdna-ssl.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='https://liliputing-wpengine.netdna-ssl.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1' defer onload=''></script>
<script type='text/javascript' src='https://liliputing-wpengine.netdna-ssl.com/wp-content/plugins/wpdiscuz/assets/third-party/wpdcookiejs/customcookie.js?ver=4.8' defer onload=''></script>
<script type='text/javascript' src='https://liliputing-wpengine.netdna-ssl.com/wp-content/plugins/wpdiscuz/assets/third-party/autogrow/jquery.autogrowtextarea.min.js?ver=3.0' defer onload=''></script>
<script type='text/javascript'>
/* <![CDATA[ */
var wpdiscuzAjaxObj = {"url":"https:\/\/liliputing.com\/wp-admin\/admin-ajax.php","wpdiscuz_options":{"wc_hide_replies_text":"Hide Replies","wc_show_replies_text":"Show Replies","wc_msg_required_fields":"Please fill out required fields","wc_invalid_field":"Some of field value is invalid","wc_error_empty_text":"please fill out this field to comment","wc_error_url_text":"url is invalid","wc_error_email_text":"email address is invalid","wc_invalid_captcha":"Invalid Captcha Code","wc_login_to_vote":"You Must Be Logged In To Vote","wc_deny_voting_from_same_ip":"You are not allowed to vote for this comment","wc_self_vote":"You cannot vote for your comment","wc_vote_only_one_time":"You've already voted for this comment","wc_voting_error":"Voting Error","wc_held_for_moderate":"Comment awaiting moderation","wc_comment_edit_not_possible":"Sorry, this comment no longer possible to edit","wc_comment_not_updated":"Sorry, the comment was not updated","wc_comment_not_edited":"You've not made any changes","wc_new_comment_button_text":"new comment","wc_new_comments_button_text":"new comments","wc_new_reply_button_text":"new reply on your comment","wc_new_replies_button_text":"new replies on your comments","wc_msg_input_min_length":"Input is too short","wc_msg_input_max_length":"Input is too long","is_user_logged_in":false,"commentListLoadType":"2","commentListUpdateType":"0","commentListUpdateTimer":"60","liveUpdateGuests":"1","wc_comment_bg_color":"#FEFEFE","wc_reply_bg_color":"#F8F8F8","wordpress_comment_order":"asc","commentsVoteOrder":false,"wordpressThreadCommentsDepth":"3","wordpressIsPaginate":"","commentTextMaxLength":null,"storeCommenterData":100000,"isCaptchaInSession":true,"isGoodbyeCaptchaActive":false,"facebookAppID":"","version":"4.0.8","wc_post_id":99142,"loadLastCommentId":null,"wpDiscuzReCaptcha":true,"wpDiscuzReCaptchaSK":"6Lc8ahgUAAAAABtrmQ8EW9xqkEfAPtDeiYsIXVgn","wpDiscuzReCaptchaTheme":"light","wc_captcha_show_for_guest":1,"wc_captcha_show_for_members":"0","is_email_field_required":1,"action":"fc_data","confirm":"Are you sure you want to set this comment as","approved":"approved","unapproved":"unapproved","trash":"trashed","spam":"spam","confirm_blacklist":"Are you sure you want to move this user into blacklist","confirm_delete":"Are you sure you want to delete this comment"}};
/* ]]> */
</script>
<script type='text/javascript' src='https://liliputing-wpengine.netdna-ssl.com/wp-content/plugins/wpdiscuz/assets/js/wpdiscuz.js?ver=4.0.8' defer onload=''></script>
<script type='text/javascript' src='https://liliputing-wpengine.netdna-ssl.com/wp-content/plugins/wpdiscuz-report-flagging/resources/js/flag.js?ver=1.1.7' defer onload=''></script>
<script type='text/javascript'>
/* <![CDATA[ */
var wamVars = {"wamTestVar":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://liliputing-wpengine.netdna-ssl.com/wp-content/plugins/wpdiscuz-ads-manager/assets/js/frontend.js?ver=1.0.4' defer onload=''></script>
<!--[if lt IE 9]>
<script type='text/javascript' src='https://liliputing-wpengine.netdna-ssl.com/wp-content/themes/genesis/lib/js/html5shiv.js?ver=3.7.3' defer onload=''></script>
<![endif]-->
<script type='text/javascript' src='https://liliputing-wpengine.netdna-ssl.com/wp-content/plugins/wpdiscuz-frontend-moderation/assets/js/script.js?ver=1.0.6' defer onload=''></script>
<link rel='https://api.w.org/' href='https://liliputing.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://liliputing.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://liliputing.com/wp-includes/wlwmanifest.xml" /> 
<link rel='shortlink' href='https://liliputing.com/?p=99142' />
<link rel="alternate" type="application/json+oembed" href="https://liliputing.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fliliputing.com%2F2017%2F07%2Fandroid-o-imminent-google-releases-dev-preview-4.html" />
<link rel="alternate" type="text/xml+oembed" href="https://liliputing.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fliliputing.com%2F2017%2F07%2Fandroid-o-imminent-google-releases-dev-preview-4.html&#038;format=xml" />
<meta name="viewport" content="width=device-width, initial-scale=1"><meta property="og:image:secure_url" content="https://liliputing.com/wp-content/uploads/2017/07/android-o.jpg" data-id="sfsi"><meta property="og:image:type" content="" data-id="sfsi" /><meta property="og:image:width" content="680" data-id="sfsi" /><meta property="og:image:height" content="524" data-id="sfsi" /><meta property="og:url" content="https://liliputing.com/2017/07/android-o-imminent-google-releases-dev-preview-4.html" data-id="sfsi" /><meta property="og:description" content="Eager to get your hands on Android O, but not so excited about flashing a beta OS on your devices? You may not have to wait much longer for the next major Android release to drop. It could be happening in just a couple of weeks.

Google announced today on the Android Developers blog that Android 8.0 Dev Preview 4 is ready for download. Google says it's a near-final version of Android O. There aren't many major changes from Preview 3...  that is if you don't count all the behind-the-scenes bugs that Google squashed and code that was refined to get the OS ready for release.

A few of that updates that were mentioned are notification overlays on app icons, pop-up notification windows, basic on-device machine learning abilities, and the new picture-in-picture mode. Brad posted a list of the other new features and enhancements you'll see in Android O back in March.

If a final preview is stable enough for you, remember that you'll need a compatible device* to try it out. The official list includes the Pixel, Pixel XL, Pixel C, Nexus 5X, Nexus 6P, and Nexus Player. Enroll your device in the Android beta program and Google will push the update automatically or download the new firmware and flash it manually.

*There's one more way that you can take Android O for a spin if your phone, tablet, or media player isn't supported. Just grab the latest version of the emulator and fire up on your laptop or desktop." data-id="sfsi" /><meta property="og:title" content="Android O imminent after Google releases Dev Preview 4" data-id="sfsi" />    	<script>
			jQuery(document).ready(function(e) {
                jQuery("body").addClass("sfsi_1.74")
            });
			function sfsi_processfurther(ref) {
				var feed_id = 'NjJmN0tRQ1R3bVhMYXl0RktaRE1nRmxzRGRVTklwUHdjT0s1dUNudFI1S0s5UXJJVkw0QlE1ZHRweWhocloxNG5BL3JZUXFWZUxERGd6UEk1N2FBampPWTArMTBNZWQwdmhGYXFyRWNSRE92Z1F3OGJ1MDBTVWxLZkF6VUM3Yjh8ZnpFWVpxZXNERUs3SEhlOFZrT1o1L08xcFh0MXptdktja3ZKc0pDT2FZOD0=';
				var feedtype = 8;
				var email = jQuery(ref).find('input[name="data[Widget][email]"]').val();
				var filter = /^([a-zA-Z0-9_\.\-])+\@(([a-zA-Z0-9\-])+\.)+([a-zA-Z0-9]{2,4})+$/;
				if ((email != "Enter your email") && (filter.test(email))) {
					if (feedtype == "8") {
						var url ="https://www.specificfeeds.com/widgets/subscribeWidget/"+feed_id+"/"+feedtype;
						window.open(url, "popupwindow", "scrollbars=yes,width=1080,height=760");
						return true;
					}
				} else {
					alert("Please enter email address");
					jQuery(ref).find('input[name="data[Widget][email]"]').focus();
					return false;
				}
			}
		</script>
        <style type="text/css" aria-selected="true">
			.sfsi_subscribe_Popinner
			{
								width: 100% !important;
				height: auto !important;
												border: 1px solid #b5b5b5 !important;
								padding: 18px 0px !important;
				background-color: #ffffff !important;
			}
			.sfsi_subscribe_Popinner form
			{
				margin: 0 20px !important;
			}
			.sfsi_subscribe_Popinner h5
			{
				font-family: Helvetica,Arial,sans-serif !important;
								font-weight: bold !important;
								color: #000000 !important;
				font-size: 16px !important;
				text-align: center !important;
				margin: 0 0 10px !important;
    			padding: 0 !important;
			}
			.sfsi_subscription_form_field {
				margin: 5px 0 !important;
				width: 100% !important;
				display: inline-flex;
				display: -webkit-inline-flex;
			}
			.sfsi_subscription_form_field input {
				width: 100% !important;
				padding: 10px 0px !important;
			}
			.sfsi_subscribe_Popinner input[type=email]
			{
				font-family: Helvetica,Arial,sans-serif !important;
								font-style: normal !important;
								color: #000000 !important;
				font-size: 14px !important;
				text-align: center !important;
			}
			.sfsi_subscribe_Popinner input[type=email]::-webkit-input-placeholder {
			   	font-family: Helvetica,Arial,sans-serif !important;
								font-style: normal !important;
								color: #000000 !important;
				font-size: 14px !important;
				text-align: center !important;
			}
			.sfsi_subscribe_Popinner input[type=email]:-moz-placeholder { /* Firefox 18- */
			    font-family: Helvetica,Arial,sans-serif !important;
								font-style: normal !important;
								color: #000000 !important;
				font-size: 14px !important;
				text-align: center !important;
			}
			.sfsi_subscribe_Popinner input[type=email]::-moz-placeholder {  /* Firefox 19+ */
			    font-family: Helvetica,Arial,sans-serif !important;
								font-style: normal !important;
								color: #000000 !important;
				font-size: 14px !important;
				text-align: center !important;
			}
			.sfsi_subscribe_Popinner input[type=email]:-ms-input-placeholder {  
			  	font-family: Helvetica,Arial,sans-serif !important;
								font-style: normal !important;
								color: #000000 !important;
				font-size: 14px !important;
				text-align: center !important;
			}
			.sfsi_subscribe_Popinner input[type=submit]
			{
				font-family: Helvetica,Arial,sans-serif !important;
								font-weight: bold !important;
								color: #000000 !important;
				font-size: 16px !important;
				text-align: center !important;
				background-color: #dedede !important;
			}
		</style>
	<style type="text/css">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</style>
			
<link rel='dns-prefetch' href='//v0.wordpress.com'>
<link rel='dns-prefetch' href='//i0.wp.com'>
<link rel='dns-prefetch' href='//i1.wp.com'>
<link rel='dns-prefetch' href='//i2.wp.com'>
<style type="text/css">.site-header .title-area { background: url(https://liliputing-wpengine.netdna-ssl.com/wp-content/uploads/2013/09/LiliputingLogo320.png) no-repeat !important; }</style>
<!-- SHARETHROUGH CORE TECHNOLOGY -->
<script type="text/javascript" src="//native.sharethrough.com/assets/sfp.js"></script>


<script type="text/javascript" id="nsgpt" data-channel="general" src="//cdn.nsstatic.net/ns/liliputing.com.js" async="true"></script>

<script async='async' src='https://www.googletagservices.com/tag/js/gpt.js'></script>
<script>
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
</script>

<script>
  googletag.cmd.push(function() {
    googletag.defineSlot('/1018314/Below_the_post_2', [300, 250], 'div-gpt-ad-1471700729982-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.pubads().collapseEmptyDivs();
    googletag.enableServices();
  });
</script>

<script type="text/javascript" async="async" src="https://widgets.outbrain.com/outbrain.js"></script
 </head>
<body class="post-template-default single single-post postid-99142 single-format-standard custom-header header-image content-sidebar eleven40-pro-blue" itemscope itemtype="https://schema.org/WebPage"><script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-4642989-1', 'auto');
  ga('send', 'pageview', {
    'dimension1':'Lee Mathews'
  });

</script>

<div id="fb-root"></div>
<script>(function(d, s, id) {
  var js, fjs = d.getElementsByTagName(s)[0];
  if (d.getElementById(id)) return;
  js = d.createElement(s); js.id = id;
  js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&appId=123309376161&version=v2.3";
  fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));</script>


 <div class="site-container"><header class="site-header" itemscope itemtype="https://schema.org/WPHeader"><div class="wrap"><div class="title-area"><p class="site-title" itemprop="headline"><a href="https://liliputing.com/">Liliputing</a></p></div><div class="widget-area header-widget-area"><section id="nav_menu-3" class="widget widget_nav_menu"><div class="widget-wrap"><nav class="nav-header" itemscope itemtype="https://schema.org/SiteNavigationElement"><ul id="menu-nav" class="menu genesis-nav-menu"><li id="menu-item-83728" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-83728"><a rel="nofollow" href="http://lpxshow.com/" itemprop="url"><span itemprop="name">LPX Show</span></a></li>
<li id="menu-item-44423" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-44423"><a href="http://liliputing.com/tag/mini-pc" itemprop="url"><span itemprop="name">Mini PCs</span></a></li>
<li id="menu-item-59018" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-59018"><a href="https://liliputing.com/category/reviews" itemprop="url"><span itemprop="name">Reviews</span></a></li>
<li id="menu-item-44420" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-44420"><a href="http://liliputing.com/category/deals" itemprop="url"><span itemprop="name">Deals</span></a></li>
<li id="menu-item-66650" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-66650"><a rel="nofollow" href="http://www.amazon.com/Best-Sellers-Computers-Accessories/zgbs/pc/ref=as_li_ss_tl?_encoding=UTF8&#038;linkCode=ll2&#038;tag=liliputing_shop-20&#038;linkId=93aaf7ba4e36ed56d46003558471548d" itemprop="url"><span itemprop="name">Shop</span></a></li>
<li id="menu-item-72206" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-72206"><a itemprop="url"><span itemprop="name">About</span></a>
<ul  class="sub-menu">
	<li id="menu-item-44422" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-44422"><a href="http://liliputing.com/contact" itemprop="url"><span itemprop="name">Contact us</span></a></li>
	<li id="menu-item-72207" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-72207"><a href="http://liliputing.com/advertise-on-liliputing" itemprop="url"><span itemprop="name">Advertise on Liliputing</span></a></li>
	<li id="menu-item-72208" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-72208"><a href="http://liliputing.com/about" itemprop="url"><span itemprop="name">About Liliputing</span></a></li>
	<li id="menu-item-72209" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-72209"><a href="http://liliputing.com/privacy-statement" itemprop="url"><span itemprop="name">Privacy Statement</span></a></li>
</ul>
</li>
</ul></nav></div></section>
</div></div></header><div class="site-inner"><div class="wrap"><div class="content-sidebar-wrap"><div class="widget_before_content"><section id="text-391998701" class="widget widget_text"><div class="widget-wrap">			<div class="textwidget"><p><div data-ns="billboard"></div></div>
		</div></section>
</div><main class="content"><article class="post-99142 post type-post status-publish format-standard has-post-thumbnail category-news tag-android tag-android-o tag-google tag-operating-systems entry" itemscope itemtype="https://schema.org/CreativeWork"><header class="entry-header"><h1 class="entry-title" itemprop="headline">Android O imminent after Google releases Dev Preview 4</h1>
<p class="entry-meta"><time class="entry-time" itemprop="datePublished" datetime="2017-07-24T16:00:07+00:00">07/24/2017</time> at <time class="entry-time" itemprop="datePublished" datetime="2017-07-24T16:00:07+00:00">4:00 PM</time> by <span class="entry-author" itemprop="author" itemscope itemtype="https://schema.org/Person"><a href="https://liliputing.com/author/lee" class="entry-author-link" itemprop="url" rel="author"><span class="entry-author-name" itemprop="name">Lee Mathews</span></a></span> <span class="entry-comments-link"><a href="https://liliputing.com/2017/07/android-o-imminent-google-releases-dev-preview-4.html#respond">Leave a Comment</a></span>  </p></header><aside class="wpselect_before_post_content widget-area"><section id="text-391998734" class="widget widget_text"><div class="widget-wrap">			<div class="textwidget"><center>
<style>
.example_responsive_1 { width: 300px; height: 250px; }
@media(min-width: 500px) { .example_responsive_1 { width: 468px; height: 60px; } }
@media(min-width: 800px) { .example_responsive_1 { width: 728px; height: 90px; } }
</style>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- LP Responsive Content top -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-2998039209070153"
     data-ad-slot="9973754732"
     data-ad-format="auto"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></center></div>
		</div></section>
</aside><div class="entry-content" itemprop="text"><p>Eager to get your hands on Android O, but not so excited about flashing a beta OS on your devices? You may not have to wait much longer for the next major Android release to drop. It could be happening in just a couple of weeks.</p>
<p><a href="https://liliputing.com/2017/07/android-o-imminent-google-releases-dev-preview-4.html/android-o-3" rel="attachment wp-att-99143"><img src="https://i1.wp.com/liliputing.com/wp-content/plugins/lazy-load/images/1x1.trans.gif?ssl=1" data-lazy-src="https://i2.wp.com/liliputing.com/wp-content/uploads/2017/07/android-o.jpg?resize=680%2C524&#038;ssl=1" class="aligncenter size-large wp-image-99143" alt srcset="https://i2.wp.com/liliputing.com/wp-content/uploads/2017/07/android-o.jpg?w=680&amp;ssl=1 680w, https://i2.wp.com/liliputing.com/wp-content/uploads/2017/07/android-o.jpg?resize=125%2C96&amp;ssl=1 125w, https://i2.wp.com/liliputing.com/wp-content/uploads/2017/07/android-o.jpg?resize=195%2C150&amp;ssl=1 195w, https://i2.wp.com/liliputing.com/wp-content/uploads/2017/07/android-o.jpg?resize=150%2C116&amp;ssl=1 150w" sizes="(max-width: 680px) 100vw, 680px" data-recalc-dims="1"><noscript><img class="aligncenter size-large wp-image-99143" src="https://i2.wp.com/liliputing.com/wp-content/uploads/2017/07/android-o.jpg?resize=680%2C524&#038;ssl=1" alt="" srcset="https://i2.wp.com/liliputing.com/wp-content/uploads/2017/07/android-o.jpg?w=680&amp;ssl=1 680w, https://i2.wp.com/liliputing.com/wp-content/uploads/2017/07/android-o.jpg?resize=125%2C96&amp;ssl=1 125w, https://i2.wp.com/liliputing.com/wp-content/uploads/2017/07/android-o.jpg?resize=195%2C150&amp;ssl=1 195w, https://i2.wp.com/liliputing.com/wp-content/uploads/2017/07/android-o.jpg?resize=150%2C116&amp;ssl=1 150w" sizes="(max-width: 680px) 100vw, 680px" data-recalc-dims="1" /></noscript></a>Google announced today on the Android Developers blog that Android 8.0 Dev <a href="https://android-developers.googleblog.com/2017/07/developer-preview-4-now-available.html">Preview 4 is ready for download</a>. Google says it&#8217;s a &#8220;near-final version of Android O.&#8221; There aren&#8217;t many major changes from <a href="https://liliputing.com/2017/06/google-release-android-o-developer-preview-3-final-apis.html">Preview 3</a>&#8230;  that is if you don&#8217;t count all the behind-the-scenes bugs that Google squashed and code that was refined to get the OS ready for release.</p>
<p>A few of that updates that were mentioned are notification overlays on app icons, pop-up notification windows, basic on-device machine learning abilities, and the new picture-in-picture mode. Brad posted a list of the <a href="https://liliputing.com/2017/03/whats-new-android-o.html">other new features and enhancements</a> you&#8217;ll see in Android O back in March.</p>
<p>If a final preview is stable enough for you, remember that you&#8217;ll need a compatible device* to try it out. The official list includes the Pixel, Pixel XL, Pixel C, Nexus 5X, Nexus 6P, and Nexus Player. Enroll your device in the <a href="https://android.com/beta">Android beta program</a> and Google will push the update automatically or <a href="https://developer.android.com/preview/download.html?utm_campaign=android_launch_npreview_061516&amp;utm_source=anddev&amp;utm_medium=blog#flash">download the new firmware</a> and flash it manually.</p>
<p>*There&#8217;s one more way that you can take Android O for a spin if your phone, tablet, or media player isn&#8217;t supported. Just grab the latest version of the emulator and fire up on your laptop or desktop.</p>
</div><aside class="wpselect_after_post_content widget-area"><section id="text-391998749" class="widget widget_text"><div class="widget-wrap">			<div class="textwidget"><div class="OUTBRAIN" data-widget-id= "TF_6" data-src = "" data-ob-template=“bradlinder” ></div></div>
		</div></section>
<section id="execphp-2" class="widget widget_execphp"><div class="widget-wrap">			<div class="execphpwidget"><div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon-text sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-facebook"><a rel="nofollow" data-shared="sharing-facebook-99142" class="share-facebook sd-button share-icon" href="https://liliputing.com/2017/07/android-o-imminent-google-releases-dev-preview-4.html?share=facebook" target="_blank" title="Click to share on Facebook"><span>Facebook</span></a></li><li class="share-twitter"><a rel="nofollow" data-shared="sharing-twitter-99142" class="share-twitter sd-button share-icon" href="https://liliputing.com/2017/07/android-o-imminent-google-releases-dev-preview-4.html?share=twitter" target="_blank" title="Click to share on Twitter"><span>Twitter</span></a></li><li class="share-google-plus-1"><a rel="nofollow" data-shared="sharing-google-99142" class="share-google-plus-1 sd-button share-icon" href="https://liliputing.com/2017/07/android-o-imminent-google-releases-dev-preview-4.html?share=google-plus-1" target="_blank" title="Click to share on Google+"><span>Google</span></a></li><li class="share-reddit"><a rel="nofollow" data-shared="" class="share-reddit sd-button share-icon" href="https://liliputing.com/2017/07/android-o-imminent-google-releases-dev-preview-4.html?share=reddit" target="_blank" title="Click to share on Reddit"><span>Reddit</span></a></li><li class="share-email"><a rel="nofollow" data-shared="" class="share-email sd-button share-icon" href="https://liliputing.com/2017/07/android-o-imminent-google-releases-dev-preview-4.html?share=email" target="_blank" title="Click to email this to a friend"><span>Email</span></a></li><li class="share-end"></li></ul></div></div></div></div>
		</div></section>
<section id="text-391998731" class="widget widget_text"><div class="widget-wrap">			<div class="textwidget"><div data-ns="native" data-sharethrough="7ebdf04f"></div></div>
		</div></section>
<section id="text-391998754" class="widget widget_text"><div class="widget-wrap">			<div class="textwidget"><center><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Liliputing content bottom 300 -->
<ins class="adsbygoogle"
     style="display:inline-block;width:300px;height:250px"
     data-ad-client="ca-pub-2998039209070153"
     data-ad-slot="9444883537"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></center></div>
		</div></section>
</aside><footer class="entry-footer"></footer></article>    <div class="wpdiscuz_top_clearing"></div>
                    <div id="comments" class="comments-area">
                    <div id="respond" style="width: 0;height: 0;clear: both;margin: 0;padding: 0;"></div>
                            <h3 id="wc-comment-header">Leave a Reply</h3>
                <div id="wpcomm" class="wpdiscuz_unauth">
                            <div class="wc-comment-bar">
                    <p class="wc-comment-title">
                        Be the First to Comment!                    </p>
                    <div class="wpdiscuz_clear"></div>
                </div>
                                    <div class="wc_social_plugin_wrapper">
                
<!--
	wsl_render_auth_widget
	WordPress Social Login 2.3.3.
	http://wordpress.org/plugins/wordpress-social-login/
-->

<style type="text/css">
.wp-social-login-connect-with{}.wp-social-login-provider-list{}.wp-social-login-provider-list a{}.wp-social-login-provider-list img{}.wsl_connect_with_provider{}</style>

<div class="wp-social-login-widget">

	<div class="wp-social-login-connect-with">Login with</div>

	<div class="wp-social-login-provider-list">

		<a rel="nofollow" href="https://liliputing.com/wp-login.php?wpe-login=liliputing&#038;action=wordpress_social_authenticate&#038;mode=login&#038;provider=Facebook&#038;redirect_to=https%3A%2F%2Fliliputing.com%2F2017%2F07%2Fandroid-o-imminent-google-releases-dev-preview-4.html" title="Connect with Facebook" class="wp-social-login-provider wp-social-login-provider-facebook" data-provider="Facebook">
			<img alt="Facebook" title="Connect with Facebook" src="https://liliputing-wpengine.netdna-ssl.com/wp-content/plugins/wordpress-social-login/assets/img/32x32/wpzoom/facebook.png" />
		</a>

		<a rel="nofollow" href="https://liliputing.com/wp-login.php?wpe-login=liliputing&#038;action=wordpress_social_authenticate&#038;mode=login&#038;provider=Google&#038;redirect_to=https%3A%2F%2Fliliputing.com%2F2017%2F07%2Fandroid-o-imminent-google-releases-dev-preview-4.html" title="Connect with Google" class="wp-social-login-provider wp-social-login-provider-google" data-provider="Google">
			<img alt="Google" title="Connect with Google" src="https://liliputing-wpengine.netdna-ssl.com/wp-content/plugins/wordpress-social-login/assets/img/32x32/wpzoom/google.png" />
		</a>

		<a rel="nofollow" href="https://liliputing.com/wp-login.php?wpe-login=liliputing&#038;action=wordpress_social_authenticate&#038;mode=login&#038;provider=Twitter&#038;redirect_to=https%3A%2F%2Fliliputing.com%2F2017%2F07%2Fandroid-o-imminent-google-releases-dev-preview-4.html" title="Connect with Twitter" class="wp-social-login-provider wp-social-login-provider-twitter" data-provider="Twitter">
			<img alt="Twitter" title="Connect with Twitter" src="https://liliputing-wpengine.netdna-ssl.com/wp-content/plugins/wordpress-social-login/assets/img/32x32/wpzoom/twitter.png" />
		</a>

		<a rel="nofollow" href="https://liliputing.com/wp-login.php?wpe-login=liliputing&#038;action=wordpress_social_authenticate&#038;mode=login&#038;provider=Yahoo&#038;redirect_to=https%3A%2F%2Fliliputing.com%2F2017%2F07%2Fandroid-o-imminent-google-releases-dev-preview-4.html" title="Connect with Yahoo!" class="wp-social-login-provider wp-social-login-provider-yahoo" data-provider="Yahoo">
			<img alt="Yahoo!" title="Connect with Yahoo!" src="https://liliputing-wpengine.netdna-ssl.com/wp-content/plugins/wordpress-social-login/assets/img/32x32/wpzoom/yahoo.png" />
		</a>

		<a rel="nofollow" href="https://liliputing.com/wp-login.php?wpe-login=liliputing&#038;action=wordpress_social_authenticate&#038;mode=login&#038;provider=Disqus&#038;redirect_to=https%3A%2F%2Fliliputing.com%2F2017%2F07%2Fandroid-o-imminent-google-releases-dev-preview-4.html" title="Connect with Disqus" class="wp-social-login-provider wp-social-login-provider-disqus" data-provider="Disqus">
			<img alt="Disqus" title="Connect with Disqus" src="https://liliputing-wpengine.netdna-ssl.com/wp-content/plugins/wordpress-social-login/assets/img/32x32/wpzoom/disqus.png" />
		</a>

		<a rel="nofollow" href="https://liliputing.com/wp-login.php?wpe-login=liliputing&#038;action=wordpress_social_authenticate&#038;mode=login&#038;provider=Reddit&#038;redirect_to=https%3A%2F%2Fliliputing.com%2F2017%2F07%2Fandroid-o-imminent-google-releases-dev-preview-4.html" title="Connect with Reddit" class="wp-social-login-provider wp-social-login-provider-reddit" data-provider="Reddit">
			<img alt="Reddit" title="Connect with Reddit" src="https://liliputing-wpengine.netdna-ssl.com/wp-content/plugins/wordpress-social-login/assets/img/32x32/wpzoom/reddit.png" />
		</a>

		<a rel="nofollow" href="https://liliputing.com/wp-login.php?wpe-login=liliputing&#038;action=wordpress_social_authenticate&#038;mode=login&#038;provider=Stackoverflow&#038;redirect_to=https%3A%2F%2Fliliputing.com%2F2017%2F07%2Fandroid-o-imminent-google-releases-dev-preview-4.html" title="Connect with Stackoverflow" class="wp-social-login-provider wp-social-login-provider-stackoverflow" data-provider="Stackoverflow">
			<img alt="Stackoverflow" title="Connect with Stackoverflow" src="https://liliputing-wpengine.netdna-ssl.com/wp-content/plugins/wordpress-social-login/assets/img/32x32/wpzoom/stackoverflow.png" />
		</a>

		<a rel="nofollow" href="https://liliputing.com/wp-login.php?wpe-login=liliputing&#038;action=wordpress_social_authenticate&#038;mode=login&#038;provider=GitHub&#038;redirect_to=https%3A%2F%2Fliliputing.com%2F2017%2F07%2Fandroid-o-imminent-google-releases-dev-preview-4.html" title="Connect with GitHub" class="wp-social-login-provider wp-social-login-provider-github" data-provider="GitHub">
			<img alt="GitHub" title="Connect with GitHub" src="https://liliputing-wpengine.netdna-ssl.com/wp-content/plugins/wordpress-social-login/assets/img/32x32/wpzoom/github.png" />
		</a>

	</div>

	<div class="wp-social-login-widget-clearing"></div>

</div>

<!-- wsl_render_auth_widget -->

            </div>
                            <div class="wpdiscuz-subscribe-bar">
                                            <form action="https://liliputing.com/wp-admin/admin-ajax.php?action=addSubscription" method="post" id="wpdiscuz-subscribe-form">
                            <div class="wpdiscuz-subscribe-form-intro">Notify of </div>
                            <div class="wpdiscuz-subscribe-form-option" style="width:40%;">
                                <select class="wpdiscuz_select" name="wpdiscuzSubscriptionType" >
                                                                            <option value="post">new follow-up comments</option>
                                                                                                                <option value="all_comment" >new replies to my comments</option>
                                                                    </select>
                            </div>
                                                            <div class="wpdiscuz-item wpdiscuz-subscribe-form-email">
                                    <input  class="email" type="email" name="wpdiscuzSubscriptionEmail" required="required" value="" placeholder="Email"/>
                                </div>
                                                        <div class="wpdiscuz-subscribe-form-button">
                                <input id="wpdiscuz_subscription_button" type="submit" value="&rsaquo;" name="wpdiscuz_subscription_button" />
                            </div> 
                            <input type="hidden" id="wpdiscuz_subscribe_form_nonce" name="wpdiscuz_subscribe_form_nonce" value="e4e1353608" /><input type="hidden" name="_wp_http_referer" value="/2017/07/android-o-imminent-google-releases-dev-preview-4.html" />                            <input type="hidden" value="99142" name="wpdiscuzSubscriptionPostId" />
                        </form>
                                        <div class="wpdiscuz_clear"></div>
                                    </div>
                        <div class="wc-form-wrapper wc-main-form-wrapper"  id='wc-main-form-wrapper-0_0' >
            <div class="wpdiscuz-comment-message" style="display: block;"></div>
                                        <form class="wc_comm_form wc_main_comm_form" method="post"  enctype="multipart/form-data">
                    <div class="wc-field-comment">
                                                                                <div class="wc-field-avatararea">
                                <img src="https://liliputing-wpengine.netdna-ssl.com/wp-content/plugins/lazy-load/images/1x1.trans.gif" data-lazy-src="https://secure.gravatar.com/avatar/?s=48&#038;d=mm&#038;r=g" alt="avatar" srcset="https://secure.gravatar.com/avatar/?s=96&amp;d=mm&amp;r=g 2x" class="avatar avatar-48 photo avatar-default" height="48" width="48"><noscript><img alt='avatar' src='https://secure.gravatar.com/avatar/?s=48&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/?s=96&amp;d=mm&amp;r=g 2x' class='avatar avatar-48 photo avatar-default' height='48' width='48' /></noscript>                            </div>
                                                <div class="wpdiscuz-item wc-field-textarea" >
                            <div class="wpdiscuz-textarea-wrap ">
                                <textarea id="wc-textarea-0_0"   placeholder="Start the discussion" required name="wc_comment" class="wc_comment wpd-field"></textarea>
                                                                                            </div>
                        </div>
                        <div class="clearfix"></div>
                    </div>
                    <div class="wc-form-footer"  style="display: none;"> 
                                <div class="wpd-form-row">
                    <div class="wpd-form-col-full">
                        <div class="wpdiscuz-item wpd-has-icon">
                                <div class="wpd-field-icon"><i class="fa fa-user"></i></div>
                                                <input required="required" class="wc_name wpd-field" type="text" name="wc_name" value="" placeholder="Name" maxlength="50" pattern=".{3,50}" title="">
                            </div>
                        <div class="wpdiscuz-item wpd-has-icon">
                                    <div class="wpd-field-icon"><i class="fa fa-at"></i></div>
                                                <input required="required" class="wc_email wpd-field" type="email" name="wc_email" value="" placeholder="Email">
                            </div>
                    <div class="wc-field-captcha wpdiscuz-item">
            <div class="wpdiscuz-recaptcha" id='wpdiscuz-recaptcha-0_0'></div>
            <input id='wpdiscuz-recaptcha-field-0_0' type='hidden' name='wpdiscuz_recaptcha' value='' required="required" class="wpdiscuz_reset"/>
            <div class="clearfix"></div>
        </div>
                <div class="wc-field-submit">
                                                <div class="wc_notification_checkboxes" style="display:block">
                                                    <input id="wc_notification_new_comment-0_0" class="wc_notification_new_comment-0_0" value="comment"  type="checkbox" name="wpdiscuz_notification_type" /> <label class="wc-label-comment-notify" for="wc_notification_new_comment-0_0">Notify of new replies to this comment</label><br />
                                                </div>
                                        <input class="wc_comm_submit wc_not_clicked button alt" type="submit" name="submit" value="Post Comment">
        </div>
                </div>
                    <div class="clearfix"></div>
        </div>
                            </div>
                    <div class="clearfix"></div>
                    <input type="hidden" class="wpdiscuz_unique_id" value="0_0" name="wpdiscuz_unique_id">
                </form>
                    </div>
                <div id = "wpdiscuz_hidden_secondary_form" style = "display: none;">
                    <div class="wc-form-wrapper wc-secondary-form-wrapper"  id='wc-secondary-form-wrapper-wpdiscuzuniqueid'  style='display: none;' >
            <div class="wpdiscuz-comment-message" style="display: block;"></div>
                            <div class="wc-secondary-forms-social-content"></div>
                                        <form class="wc_comm_form wc-secondary-form-wrapper" method="post"  enctype="multipart/form-data">
                    <div class="wc-field-comment">
                                                                                <div class="wc-field-avatararea">
                                <img src="https://liliputing-wpengine.netdna-ssl.com/wp-content/plugins/lazy-load/images/1x1.trans.gif" data-lazy-src="https://secure.gravatar.com/avatar/?s=48&#038;d=mm&#038;r=g" alt="avatar" srcset="https://secure.gravatar.com/avatar/?s=96&amp;d=mm&amp;r=g 2x" class="avatar avatar-48 photo avatar-default" height="48" width="48"><noscript><img alt='avatar' src='https://secure.gravatar.com/avatar/?s=48&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/?s=96&amp;d=mm&amp;r=g 2x' class='avatar avatar-48 photo avatar-default' height='48' width='48' /></noscript>                            </div>
                                                <div class="wpdiscuz-item wc-field-textarea" >
                            <div class="wpdiscuz-textarea-wrap ">
                                <textarea id="wc-textarea-wpdiscuzuniqueid"   placeholder="Join the discussion" required name="wc_comment" class="wc_comment wpd-field"></textarea>
                                                                                            </div>
                        </div>
                        <div class="clearfix"></div>
                    </div>
                    <div class="wc-form-footer"  style="display: none;"> 
                                <div class="wpd-form-row">
                    <div class="wpd-form-col-full">
                        <div class="wpdiscuz-item wpd-has-icon">
                                <div class="wpd-field-icon"><i class="fa fa-user"></i></div>
                                                <input required="required" class="wc_name wpd-field" type="text" name="wc_name" value="" placeholder="Name" maxlength="50" pattern=".{3,50}" title="">
                            </div>
                        <div class="wpdiscuz-item wpd-has-icon">
                                    <div class="wpd-field-icon"><i class="fa fa-at"></i></div>
                                                <input required="required" class="wc_email wpd-field" type="email" name="wc_email" value="" placeholder="Email">
                            </div>
                    <div class="wc-field-captcha wpdiscuz-item">
            <div class="wpdiscuz-recaptcha" id='wpdiscuz-recaptcha-wpdiscuzuniqueid'></div>
            <input id='wpdiscuz-recaptcha-field-wpdiscuzuniqueid' type='hidden' name='wpdiscuz_recaptcha' value='' required="required" class="wpdiscuz_reset"/>
            <div class="clearfix"></div>
        </div>
                <div class="wc-field-submit">
                                                <div class="wc_notification_checkboxes" style="display:block">
                                                    <input id="wc_notification_new_comment-wpdiscuzuniqueid" class="wc_notification_new_comment-wpdiscuzuniqueid" value="comment"  type="checkbox" name="wpdiscuz_notification_type" /> <label class="wc-label-comment-notify" for="wc_notification_new_comment-wpdiscuzuniqueid">Notify of new replies to this comment</label><br />
                                                </div>
                                        <input class="wc_comm_submit wc_not_clicked button alt" type="submit" name="submit" value="Post Comment">
        </div>
                </div>
                    <div class="clearfix"></div>
        </div>
                            </div>
                    <div class="clearfix"></div>
                    <input type="hidden" class="wpdiscuz_unique_id" value="wpdiscuzuniqueid" name="wpdiscuz_unique_id">
                </form>
                    </div>
                </div>
                    

                        
                
                                <div id="wcThreadWrapper" class="wc-thread-wrapper">
                                    
                    <div class="wpdiscuz-comment-pagination">
                                            </div>
                </div>
                <div class="wpdiscuz_clear"></div>
                                            </div>
        </div>
        <div class="wpdiscuz-loading-bar wpdiscuz-loading-bar-unauth"><img class="wpdiscuz-loading-bar-img" alt="wpDiscuz" src="https://liliputing-wpengine.netdna-ssl.com/wp-content/plugins/wpdiscuz/assets/img/loading.gif" width="32" height="25" /></div>
        </main><aside class="sidebar sidebar-primary widget-area" role="complementary" aria-label="Primary Sidebar" itemscope itemtype="https://schema.org/WPSideBar"><section id="sfsi-widget-2" class="widget sfsi"><div class="widget-wrap">            <div class="sfsi_widget" data-position="widget">   
				<div id='sfsi_wDiv'></div>
                    <div class="norm_row sfsi_wDiv"  style="width:280px;text-align:left;position:absolute;"><div style='width:48px; height:48px;margin-left:8px;margin-bottom:5px;' class='sfsi_wicons shuffeldiv '><div class='inerCnt'><a class=' sficn' effect='fade_in' target='_blank'  href='https://twitter.com/liliputingnews' id='sfsiid_twitter' alt='Twitter' style='opacity:0.6' ><img alt='Twitter' title='Twitter' src='https://liliputing-wpengine.netdna-ssl.com/wp-content/plugins/ultimate-social-media-icons/images/icons_theme/flat/flat_twitter.png' width='48' height='48' style='' class='sfcm sfsi_wicon' effect='fade_in'   /></a></div></div><div style='width:48px; height:48px;margin-left:8px;margin-bottom:5px;' class='sfsi_wicons shuffeldiv '><div class='inerCnt'><a class=' sficn' effect='fade_in' target='_blank'  href='https://plus.google.com/u/0/b/106676686837148977188/+Liliputing/posts' id='sfsiid_google' alt='Google+' style='opacity:0.6' ><img alt='Google+' title='Google+' src='https://liliputing-wpengine.netdna-ssl.com/wp-content/plugins/ultimate-social-media-icons/images/icons_theme/flat/flat_google.png' width='48' height='48' style='' class='sfcm sfsi_wicon' effect='fade_in'   /></a></div></div><div style='width:48px; height:48px;margin-left:8px;margin-bottom:5px;' class='sfsi_wicons shuffeldiv '><div class='inerCnt'><a class=' sficn' effect='fade_in' target='_blank'  href='https://www.facebook.com/Liliputing' id='sfsiid_facebook' alt='Facebook' style='opacity:0.6' ><img alt='Facebook' title='Facebook' src='https://liliputing-wpengine.netdna-ssl.com/wp-content/plugins/ultimate-social-media-icons/images/icons_theme/flat/flat_facebook.png' width='48' height='48' style='' class='sfcm sfsi_wicon' effect='fade_in'   /></a></div></div><div style='width:48px; height:48px;margin-left:8px;margin-bottom:5px;' class='sfsi_wicons shuffeldiv '><div class='inerCnt'><a class=' sficn' effect='fade_in' target='_blank'  href='http://youtube.com/bradlinder' id='sfsiid_youtube' alt='YouTube' style='opacity:0.6' ><img alt='YouTube' title='YouTube' src='https://liliputing-wpengine.netdna-ssl.com/wp-content/plugins/ultimate-social-media-icons/images/icons_theme/flat/flat_youtube.png' width='48' height='48' style='' class='sfcm sfsi_wicon' effect='fade_in'   /></a></div></div><div style='width:48px; height:48px;margin-left:8px;margin-bottom:5px;' class='sfsi_wicons shuffeldiv '><div class='inerCnt'><a class=' sficn' effect='fade_in' target='_blank'  href='http://feeds.feedburner.com/Liliputing' id='sfsiid_rss' alt='RSS' style='opacity:0.6' ><img alt='RSS' title='RSS' src='https://liliputing-wpengine.netdna-ssl.com/wp-content/plugins/ultimate-social-media-icons/images/icons_theme/flat/flat_rss.png' width='48' height='48' style='' class='sfcm sfsi_wicon' effect='fade_in'   /></a></div></div></div ><div id="sfsi_holder" class="sfsi_holders" style="position: relative; float: left;width:100%;z-index:-1;"></div ><script>jQuery(".sfsi_widget").each(function( index ) {
					if(jQuery(this).attr("data-position") == "widget")
					{
						var wdgt_hght = jQuery(this).children(".norm_row.sfsi_wDiv").height();
						var title_hght = jQuery(this).parent(".widget.sfsi").children(".widget-title").height();
						var totl_hght = parseInt( title_hght ) + parseInt( wdgt_hght );
						jQuery(this).parent(".widget.sfsi").css("min-height", totl_hght+"px");
					}
				});</script>	      		<div style="clear: both;"></div>
            </div>
            </div></section>
<section id="search-4" class="widget widget_search"><div class="widget-wrap"><form class="search-form" itemprop="potentialAction" itemscope itemtype="https://schema.org/SearchAction" method="get" action="https://liliputing.com/" role="search"><meta itemprop="target" content="https://liliputing.com/?s={s}"/><input itemprop="query-input" type="search" name="s" placeholder="Search this website &#x2026;" /><input type="submit" value="Search"  /></form></div></section>
<section id="text-391998718" class="widget widget_text"><div class="widget-wrap">			<div class="textwidget"><div data-ns="halfpage"></div>

</div>
		</div></section>
<section id="featured-post-2" class="widget featured-content featuredpost"><div class="widget-wrap"><h4 class="widget-title widgettitle">Latest News</h4>
<article class="post-99140 post type-post status-publish format-standard has-post-thumbnail category-news tag-galaxy-s8-active tag-leaks tag-samsung tag-smartphones entry"><a href="https://liliputing.com/2017/07/galaxy-s8-active-leak-shows-samsung-sticking-flat-display.html" class="alignright" aria-hidden="true"><img width="125" height="85" src="https://i2.wp.com/liliputing.com/wp-content/uploads/2017/07/s8-active.jpg?fit=125%2C85&amp;ssl=1" class="entry-image attachment-post" alt="Galaxy S8 Active leak shows Samsung sticking with a flat display" itemprop="image" srcset="https://i2.wp.com/liliputing.com/wp-content/uploads/2017/07/s8-active.jpg?w=690&amp;ssl=1 690w, https://i2.wp.com/liliputing.com/wp-content/uploads/2017/07/s8-active.jpg?resize=125%2C85&amp;ssl=1 125w, https://i2.wp.com/liliputing.com/wp-content/uploads/2017/07/s8-active.jpg?resize=680%2C460&amp;ssl=1 680w, https://i2.wp.com/liliputing.com/wp-content/uploads/2017/07/s8-active.jpg?resize=200%2C135&amp;ssl=1 200w, https://i2.wp.com/liliputing.com/wp-content/uploads/2017/07/s8-active.jpg?resize=150%2C102&amp;ssl=1 150w" sizes="(max-width: 125px) 100vw, 125px" /></a><header class="entry-header"><h2 class="entry-title" itemprop="headline"><a href="https://liliputing.com/2017/07/galaxy-s8-active-leak-shows-samsung-sticking-flat-display.html">Galaxy S8 Active leak shows Samsung sticking with a flat display</a></h2></header><div class="entry-content"><p>Samsung equipped the Galaxy S7 with a flat (albeit beautiful) display. You could &#x02026; <a href="https://liliputing.com/2017/07/galaxy-s8-active-leak-shows-samsung-sticking-flat-display.html" class="more-link">[Read More...]</a></p></div></article><article class="post-99142 post type-post status-publish format-standard has-post-thumbnail category-news tag-android tag-android-o tag-google tag-operating-systems entry"><a href="https://liliputing.com/2017/07/android-o-imminent-google-releases-dev-preview-4.html" class="alignright" aria-hidden="true"><img width="125" height="96" src="https://i2.wp.com/liliputing.com/wp-content/uploads/2017/07/android-o.jpg?fit=125%2C96&amp;ssl=1" class="entry-image attachment-post" alt="Android O imminent after Google releases Dev Preview 4" itemprop="image" srcset="https://i2.wp.com/liliputing.com/wp-content/uploads/2017/07/android-o.jpg?w=680&amp;ssl=1 680w, https://i2.wp.com/liliputing.com/wp-content/uploads/2017/07/android-o.jpg?resize=125%2C96&amp;ssl=1 125w, https://i2.wp.com/liliputing.com/wp-content/uploads/2017/07/android-o.jpg?resize=195%2C150&amp;ssl=1 195w, https://i2.wp.com/liliputing.com/wp-content/uploads/2017/07/android-o.jpg?resize=150%2C116&amp;ssl=1 150w" sizes="(max-width: 125px) 100vw, 125px" /></a><header class="entry-header"><h2 class="entry-title" itemprop="headline"><a href="https://liliputing.com/2017/07/android-o-imminent-google-releases-dev-preview-4.html">Android O imminent after Google releases Dev Preview 4</a></h2></header><div class="entry-content"><p>Eager to get your hands on Android O, but not so excited about flashing a beta &#x02026; <a href="https://liliputing.com/2017/07/android-o-imminent-google-releases-dev-preview-4.html" class="more-link">[Read More...]</a></p></div></article><article class="post-99139 post type-post status-publish format-standard has-post-thumbnail category-news tag-fairphone tag-smartphones entry"><a href="https://liliputing.com/2017/07/fairphone-retires-first-phone-making-spare-parts-got-expensive.html" class="alignright" aria-hidden="true"><img width="125" height="81" src="https://i1.wp.com/liliputing.com/wp-content/uploads/2015/03/First-Gen-Fairphone.jpg?fit=125%2C81&amp;ssl=1" class="entry-image attachment-post" alt="Fairphone Retires Its First Phone Because Spare Parts Got Too Expensive" itemprop="image" srcset="https://i1.wp.com/liliputing.com/wp-content/uploads/2015/03/First-Gen-Fairphone.jpg?w=640&amp;ssl=1 640w, https://i1.wp.com/liliputing.com/wp-content/uploads/2015/03/First-Gen-Fairphone.jpg?resize=125%2C81&amp;ssl=1 125w, https://i1.wp.com/liliputing.com/wp-content/uploads/2015/03/First-Gen-Fairphone.jpg?resize=270%2C175&amp;ssl=1 270w, https://i1.wp.com/liliputing.com/wp-content/uploads/2015/03/First-Gen-Fairphone.jpg?resize=150%2C97&amp;ssl=1 150w, https://i1.wp.com/liliputing.com/wp-content/uploads/2015/03/First-Gen-Fairphone.jpg?resize=300%2C194&amp;ssl=1 300w" sizes="(max-width: 125px) 100vw, 125px" /></a><header class="entry-header"><h2 class="entry-title" itemprop="headline"><a href="https://liliputing.com/2017/07/fairphone-retires-first-phone-making-spare-parts-got-expensive.html">Fairphone Retires Its First Phone Because Spare Parts Got Too Expensive</a></h2></header><div class="entry-content"><p>In May 2013, Fairphone kicked off its mission to offer consumers the most &#x02026; <a href="https://liliputing.com/2017/07/fairphone-retires-first-phone-making-spare-parts-got-expensive.html" class="more-link">[Read More...]</a></p></div></article></div></section>
<section id="text-391998738" class="widget widget_text"><div class="widget-wrap">			<div class="textwidget"><center>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- LP Large Skyscraper mid-right -->
<ins class="adsbygoogle"
     style="display:inline-block;width:300px;height:600px"
     data-ad-client="ca-pub-2998039209070153"
     data-ad-slot="1806249933"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></center></div>
		</div></section>
<section id="featured-post-4" class="widget featured-content featuredpost"><div class="widget-wrap"><h4 class="widget-title widgettitle">Deals</h4>
<article class="post-99137 post type-post status-publish format-standard has-post-thumbnail category-deals tag-amazon-echo tag-bargains entry"><a href="https://liliputing.com/2017/07/deals-day-7-24-2017.html" class="alignright" aria-hidden="true"><img width="125" height="125" src="https://i2.wp.com/liliputing.com/wp-content/uploads/2017/07/echo-2.jpg?fit=125%2C125&amp;ssl=1" class="entry-image attachment-post" alt="Deals of the Day (7-24-2017)" itemprop="image" srcset="https://i2.wp.com/liliputing.com/wp-content/uploads/2017/07/echo-2.jpg?w=500&amp;ssl=1 500w, https://i2.wp.com/liliputing.com/wp-content/uploads/2017/07/echo-2.jpg?resize=125%2C125&amp;ssl=1 125w, https://i2.wp.com/liliputing.com/wp-content/uploads/2017/07/echo-2.jpg?resize=150%2C150&amp;ssl=1 150w" sizes="(max-width: 125px) 100vw, 125px" /></a><header class="entry-header"><h2 class="entry-title" itemprop="headline"><a href="https://liliputing.com/2017/07/deals-day-7-24-2017.html">Deals of the Day (7-24-2017)</a></h2></header><div class="entry-content"><p>What comes after Black Friday in July? Obviously it's Cyber Monday in July... or &#x02026; <a href="https://liliputing.com/2017/07/deals-day-7-24-2017.html" class="more-link">[Read More...]</a></p></div></article></div></section>
<section id="featured-post-5" class="widget featured-content featuredpost"><div class="widget-wrap"><h4 class="widget-title widgettitle">Featured articles</h4>
<article class="post-98946 post type-post status-publish format-standard has-post-thumbnail category-featured category-news tag-amazon-fire-hd tag-amazon-fire-hd-8 tag-amazon-fire-hd-8-tablet tag-amazon-fire-tablet tag-fire tag-fire-hd-8 tag-fire-os tag-fire-tablet tag-sd-card tag-storage entry"><a href="https://liliputing.com/2017/07/use-sd-card-amazons-fire-tablets.html" class="alignright" aria-hidden="true"><img width="109" height="125" src="https://i0.wp.com/liliputing.com/wp-content/uploads/2017/07/sd-transfer-music.jpg?fit=109%2C125&amp;ssl=1" class="entry-image attachment-post" alt="How to use an SD card with Amazon&#8217;s Fire tablets" itemprop="image" srcset="https://i0.wp.com/liliputing.com/wp-content/uploads/2017/07/sd-transfer-music.jpg?w=435&amp;ssl=1 435w, https://i0.wp.com/liliputing.com/wp-content/uploads/2017/07/sd-transfer-music.jpg?resize=109%2C125&amp;ssl=1 109w, https://i0.wp.com/liliputing.com/wp-content/uploads/2017/07/sd-transfer-music.jpg?resize=131%2C150&amp;ssl=1 131w" sizes="(max-width: 109px) 100vw, 109px" /></a><header class="entry-header"><h2 class="entry-title" itemprop="headline"><a href="https://liliputing.com/2017/07/use-sd-card-amazons-fire-tablets.html">How to use an SD card with Amazon&#8217;s Fire tablets</a></h2></header><div class="entry-content"><p>Every tablet Amazon has released in the past few years has featured a microSD &#x02026; <a href="https://liliputing.com/2017/07/use-sd-card-amazons-fire-tablets.html" class="more-link">[Read More...]</a></p></div></article><article class="post-98909 post type-post status-publish format-standard has-post-thumbnail category-featured category-news category-tutorials tag-amazon-fire tag-amazon-fire-hd tag-amazon-fire-hd-8 tag-amazon-fire-tablet tag-amazon-tablet tag-android-tablet tag-fire-os tag-fire-os-5-4 tag-google-play tag-launcher-hijack tag-tablet entry"><a href="https://liliputing.com/2017/07/making-amazons-fire-hd-8-2017-googley-play-store-third-party-launchers.html" class="alignright" aria-hidden="true"><img width="125" height="78" src="https://i0.wp.com/liliputing.com/wp-content/uploads/2017/07/fhd_gplay_02.jpg?fit=125%2C78&amp;ssl=1" class="entry-image attachment-post" alt="Making Amazon&#8217;s 2017 Fire tablets more Googley (Play Store, third-party launchers)" itemprop="image" srcset="https://i0.wp.com/liliputing.com/wp-content/uploads/2017/07/fhd_gplay_02.jpg?w=680&amp;ssl=1 680w, https://i0.wp.com/liliputing.com/wp-content/uploads/2017/07/fhd_gplay_02.jpg?resize=125%2C78&amp;ssl=1 125w, https://i0.wp.com/liliputing.com/wp-content/uploads/2017/07/fhd_gplay_02.jpg?resize=200%2C125&amp;ssl=1 200w, https://i0.wp.com/liliputing.com/wp-content/uploads/2017/07/fhd_gplay_02.jpg?resize=150%2C94&amp;ssl=1 150w" sizes="(max-width: 125px) 100vw, 125px" /></a><header class="entry-header"><h2 class="entry-title" itemprop="headline"><a href="https://liliputing.com/2017/07/making-amazons-fire-hd-8-2017-googley-play-store-third-party-launchers.html">Making Amazon&#8217;s 2017 Fire tablets more Googley (Play Store, third-party launchers)</a></h2></header><div class="entry-content"><p>Amazon's tablets run an Android-based operating system called Fire OS. While &#x02026; <a href="https://liliputing.com/2017/07/making-amazons-fire-hd-8-2017-googley-play-store-third-party-launchers.html" class="more-link">[Read More...]</a></p></div></article><article class="post-97032 post type-post status-publish format-standard has-post-thumbnail category-featured category-news tag-20-smartphone tag-20-phone tag-alcatel-pixi-4 tag-best-buy tag-ipod-touch tag-portable-media-player tag-smartphones tag-walmart-family-mobile-alcatel-pixi-4 tag-zte tag-zte-midnight-pro-4g-lte entry"><a href="https://liliputing.com/2017/05/20-android-phones-may-cheapest-ipod-touch-alternatives-available.html" class="alignright" aria-hidden="true"><img width="125" height="91" src="https://i2.wp.com/liliputing.com/wp-content/uploads/2017/05/20-phones.jpg?fit=125%2C91&amp;ssl=1" class="entry-image attachment-post" alt="$20 Android phones may be the cheapest iPod touch alternatives available" itemprop="image" srcset="https://i2.wp.com/liliputing.com/wp-content/uploads/2017/05/20-phones.jpg?w=688&amp;ssl=1 688w, https://i2.wp.com/liliputing.com/wp-content/uploads/2017/05/20-phones.jpg?resize=125%2C91&amp;ssl=1 125w, https://i2.wp.com/liliputing.com/wp-content/uploads/2017/05/20-phones.jpg?resize=680%2C494&amp;ssl=1 680w, https://i2.wp.com/liliputing.com/wp-content/uploads/2017/05/20-phones.jpg?resize=200%2C145&amp;ssl=1 200w, https://i2.wp.com/liliputing.com/wp-content/uploads/2017/05/20-phones.jpg?resize=150%2C109&amp;ssl=1 150w" sizes="(max-width: 125px) 100vw, 125px" /></a><header class="entry-header"><h2 class="entry-title" itemprop="headline"><a href="https://liliputing.com/2017/05/20-android-phones-may-cheapest-ipod-touch-alternatives-available.html">$20 Android phones may be the cheapest iPod touch alternatives available</a></h2></header><div class="entry-content"><p>Smartphones have largely replaced portable media players for most people. It's &#x02026; <a href="https://liliputing.com/2017/05/20-android-phones-may-cheapest-ipod-touch-alternatives-available.html" class="more-link">[Read More...]</a></p></div></article></div></section>
<section id="text-391998737" class="widget widget_text"><div class="widget-wrap">			<div class="textwidget"><a href="https://www.patreon.com/bradlinder?ty=h"><img src="https://i2.wp.com/liliputing.com/wp-content/uploads/2016/05/patreon_lpx.png" class="aligncenter" alt="LPX Patreon" data-recalc-dims="1"></a></div>
		</div></section>
<section id="rss-2" class="widget widget_rss"><div class="widget-wrap"><h4 class="widget-title widgettitle"><a class="rsswidget" href="http://lpxshow.com/feed/"><img class="rss-widget-icon" style="border:0" width="14" height="14" src="https://liliputing-wpengine.netdna-ssl.com/wp-includes/images/rss.png" alt="RSS" /></a> <a class="rsswidget" href="http://lpxshow.com/">Latest news from the LPX Show</a></h4>
<ul><li><a class='rsswidget' href='http://lpxshow.com/lpx-episode-14-adapted-kaomi-goetz-on-korean-international-adoptees-returning-to-korea/'>LPX Episode 14: Adapted (Kaomi Goetz on Korean international adoptees returning to Korea)</a></li><li><a class='rsswidget' href='http://lpxshow.com/lpx-episode-13-someone-is-wrong-on-the-internet-snopes-editor-brooke-binkowski-on-fake-news-real-journalism/'>LPX Episode 13: Someone is wrong on the internet! (Snopes editor Brooke Binkowski on fake news &amp; real journalism)</a></li><li><a class='rsswidget' href='http://lpxshow.com/lpx-episode-12-superbook-turns-your-smartphone-into-a-laptop/'>LPX Episode 12: Superbook turns your smartphone into a laptop</a></li></ul></div></section>
<section id="text-391998736" class="widget widget_text"><div class="widget-wrap"><h4 class="widget-title widgettitle">Subscribe to the LPX Show</h4>
			<div class="textwidget"><a href="http://lpxshow.com/subscribe/">Subscribe at LPXShow.com</a></div>
		</div></section>
<section id="text-391998727" class="widget widget_text"><div class="widget-wrap">			<div class="textwidget"><center><div data-ns="skyscraper"></div></center></div>
		</div></section>
<section id="text-391998742" class="widget widget_text"><div class="widget-wrap">			<div class="textwidget"><em>Disclosure: Some links on this page are monetized by <a rel="nofollow" href="http://go.skimlinks.com/?id=32X105&amp;xs=1&amp;url=http://skimlinks.com">Skimlinks</a> and <a rel="nofollow" href="https://affiliate-program.amazon.com/welcome">Amazon's</a> and <a rel="no follow" href="https://partnernetwork.ebay.com/en/home">eBay's</a> affiliate programs.</em></div>
		</div></section>
</aside></div></div></div> <footer class="site-footer" itemscope itemtype="https://schema.org/WPFooter"><div class="wrap"><div class="creds"><p>Copyright &#x000A9;&nbsp;2017 Liliputing · <a href="#Top">Go to top of page</a></p></div></div></footer></div><div id="nSokxlDyQmoD" class="ETAQBCZDpJUu" style="background:#dddddd;z-index:9999999; "></div>   <script type="text/javascript">/* <![CDATA[ */var anOptions ={"anOptionChoice":"2","anOptionStats":"2","anOptionAdsSelectors":"","anOptionCookie":"1","anOptionCookieLife":"30","anPageRedirect":"","anPermalink":"undefined","anOptionModalEffect":"fadeAndPop","anOptionModalspeed":"350","anOptionModalclose":true,"anOptionModalOverlay":"rgba( 0,0,0,0.8 )","anAlternativeActivation":false,"anAlternativeElement":"","anAlternativeText":"<p><strong>AdBlock detected!<\/strong><\/p>\n<p>Please add <a title=\"http:\/\/themeisle.com\/\" href=\"themeisle.com\" target=\"_blank\">www.themeisle.com<\/a> to your adblocking whitelist or disable your adblocking software.<\/p>\n","anAlternativeClone":"2","anAlternativeProperties":"","anOptionModalShowAfter":0,"anPageMD5":"","anSiteID":0,"modalHTML":"<div class=\"ETAQBCZDpJUu-default\">\n\t<h1 style=\"\">Please support Liliputing<\/h1>\n\t<p>We've detected that you're using ad blocking software.<\/p>\n<p>If you value Liliputing's coverage of mobile tech, please considering adding the site to your whitelist, or <strong>making a contribution to <a href=\"https:\/\/www.patreon.com\/bradlinder?ty=h\">our Patreon campaign<\/a><\/strong>.<\/p>\n<p>You can also contribute by\u00a0<strong><a href=\"http:\/\/amzn.to\/25JFNPM\" rel=\"nofollow\">shopping at Amazon<\/a><\/strong>. Here are some items you might want to check out:<\/p>\n<ul>\n<li><a href=\"http:\/\/amzn.to\/28NkoSj\"><strong>Best-selling laptops<\/strong><\/a><\/li>\n<li><a href=\"http:\/\/amzn.to\/28MbLVm\"><strong>Best-selling tablets<\/strong><\/a><\/li>\n<li><a href=\"http:\/\/amzn.to\/28MbP7p\"><strong>2-in-1\u00a0laptops<\/strong><\/a><\/li>\n<li><a href=\"http:\/\/amzn.to\/28NkCZM\"><strong>Chromebooks<\/strong><\/a><\/li>\n<li><a href=\"http:\/\/amzn.to\/28NjVhu\"><strong>Amazon Fire tablets<\/strong><\/a><\/li>\n<li><a href=\"http:\/\/amzn.to\/28NjZgW\"><strong>Amazon Fire TV products<\/strong><\/a><\/li>\n<li><a href=\"http:\/\/amzn.to\/28NkYiI\"><strong>Amazon Echo devices<\/strong><\/a><\/li>\n<li><a href=\"http:\/\/amzn.to\/28Wt9Hx\"><strong>Best-selling computer accessories<\/strong><\/a><\/li>\n<li><a href=\"http:\/\/amzn.to\/28QYzAn\"><strong>Best-selling cellphone accessories<\/strong><\/a><\/li>\n<\/ul>\n<p>&nbsp;<\/p>\n<p>Note that you should only see this message once every 30 days... but you may see it more often if you use a new web browser or clear your cookies.<\/p>\n<p>&nbsp;<\/p>\n<\/div>\n<a class=\"close-modal close-ETAQBCZDpJUu\">&#215;<\/a>"}/* ]]> */</script><div id="adsense" class="an-sponsored" style="position:absolute; z-index:-1; height:1px; width:1px; visibility: hidden; top: -1px; left: 0;"><img class="an-advert-banner" alt="sponsored" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"></div>        <!--facebook like and share js -->
        <div id="fb-root"></div>
		<script>(function(d, s, id) {
			var js, fjs = d.getElementsByTagName(s)[0];
		  	if (d.getElementById(id)) return;
		  	js = d.createElement(s); js.id = id;
		  	js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.5";
		  	fjs.parentNode.insertBefore(js, fjs);
		}(document, 'script', 'facebook-jssdk'));</script>
		<!--<div id="fb-root"></div>
        <script>
        (function(d, s, id) {
          var js, fjs = d.getElementsByTagName(s)[0];
          if (d.getElementById(id)) return;
          js = d.createElement(s); js.id = id;
          js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&appId=1425108201100352&version=v2.0";
          fjs.parentNode.insertBefore(js, fjs);
        }(document, 'script', 'facebook-jssdk'));</script>-->
 	         <!--google share and  like and e js -->
        <script type="text/javascript">
            window.___gcfg = {
              lang: 'en-US'
            };
            (function() {
                var po = document.createElement('script'); po.type = 'text/javascript'; po.async = true;
                po.src = 'https://apis.google.com/js/plusone.js';
                var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(po, s);
            })();
        </script>
		
		<!-- google share -->
        <script type="text/javascript">
          (function() {
            var po = document.createElement('script'); po.type = 'text/javascript'; po.async = true;
            po.src = 'https://apis.google.com/js/platform.js';
            var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(po, s);
          })();
        </script>
			<!-- twitter JS End -->
		<script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0];if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src="https://platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");</script>	
	     <script>
	    jQuery( document ).scroll(function( $ )
		{
	    	var y = jQuery(this).scrollTop();
	      	if (/Android|webOS|iPhone|iPad|iPod|BlackBerry|IEMobile|Opera Mini/i.test(navigator.userAgent))
			{	 
			   if(jQuery(window).scrollTop() + jQuery(window).height() >= jQuery(document).height()-100)
			   {
				  jQuery('.sfsi_outr_div').css({'z-index':'9996',opacity:1,top:jQuery(window).scrollTop()+"px",position:"absolute"});
				  jQuery('.sfsi_outr_div').fadeIn(200);
				  jQuery('.sfsi_FrntInner_chg').fadeIn(200);
			   }
			   else{
				   jQuery('.sfsi_outr_div').fadeOut();
				   jQuery('.sfsi_FrntInner_chg').fadeOut();
			   }
		  }
		  else
		  {
			   if(jQuery(window).scrollTop() + jQuery(window).height() >= jQuery(document).height()-3)
			   {
					jQuery('.sfsi_outr_div').css({'z-index':'9996',opacity:1,top:jQuery(window).scrollTop()+200+"px",position:"absolute"});
					jQuery('.sfsi_outr_div').fadeIn(200);
					jQuery('.sfsi_FrntInner_chg').fadeIn(200);
		  	   }
	 		   else
			   {
				 jQuery('.sfsi_outr_div').fadeOut();
				 jQuery('.sfsi_FrntInner_chg').fadeOut();
			   }
	 	  } 
		});
     </script>
     
	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/liliputing.com\/2017\/07\/android-o-imminent-google-releases-dev-preview-4.html":99142};
	</script>
	<div id="sharing_email" style="display: none;">
		<form action="/2017/07/android-o-imminent-google-releases-dev-preview-4.html" method="post">
			<label for="target_email">Send to Email Address</label>
			<input type="email" name="target_email" id="target_email" value="" />

			
				<label for="source_name">Your Name</label>
				<input type="text" name="source_name" id="source_name" value="" />

				<label for="source_email">Your Email Address</label>
				<input type="email" name="source_email" id="source_email" value="" />

						<input type="text" id="jetpack-source_f_name" name="source_f_name" class="input" value="" size="25" autocomplete="off" title="This field is for validation and should not be changed" />
			<script>jQuery( document ).ready( function(){ document.getElementById('jetpack-source_f_name').value = '' });</script>
			
			<img style="float: right; display: none" class="loading" src="https://liliputing-wpengine.netdna-ssl.com/wp-content/plugins/jetpack/modules/sharedaddy/images/loading.gif" alt="loading" width="16" height="16" />
			<input type="submit" value="Send Email" class="sharing_send" />
			<a rel="nofollow" href="#cancel" class="sharing_cancel">Cancel</a>

			<div class="errors errors-1" style="display: none;">
				Post was not sent - check your email addresses!			</div>

			<div class="errors errors-2" style="display: none;">
				Email check failed, please try again			</div>

			<div class="errors errors-3" style="display: none;">
				Sorry, your blog cannot share posts by email.			</div>
		</form>
	</div>
<div class="wpdiscuz-mod-email"></div><div class="wpdiscuz-mod-email-form" style="display: none;"><span class="wpdiscuz-mod-author">You are going to send email to <em></em></span><i class="fa fa-times"></i><div style="clear: both;"></div><input placeholder="Email Subject" type="text" class="wpdiscuz-mod-subj" value="" /><textarea class="wpdiscuz-mod-msg" placeholder="Enter your message here"></textarea><br /><div class="wpdiscuz-mod-button-align"><button type="button" class="wpdiscuz-mod-send">Send</button></div></div><div class="wpdiscuz-mod-moving" style="display: none;"></div><div class="wpdiscuz-mod-move-form" style="display: none;"><span class="wpdiscuz-mod-author">Move Comment<br /><em></em></span><i class="fa fa-times"></i><div style="clear: both;"></div><div style="position: relative;"><input type="text" class="wpdiscuz-mod-post" placeholder="Enter post title..." /><div class="wpdiscuz-mod-posts"></div></div><div class="wpdiscuz-mod-button-align"><button type="button" class="wpdiscuz-mod-move">Move</button></div></div><script type='text/javascript' src='https://liliputing-wpengine.netdna-ssl.com/wp-content/plugins/jetpack/modules/photon/photon.js?ver=20130122' defer onload=''></script>
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201730' defer onload=''></script>
<script type='text/javascript' src='https://liliputing-wpengine.netdna-ssl.com/wp-includes/js/jquery/ui/core.min.js?ver=1.11.4' defer onload=''></script>
<script type='text/javascript' src='https://liliputing-wpengine.netdna-ssl.com/wp-content/plugins/ultimate-social-media-icons/js/shuffle/modernizr.custom.min.js?ver=4.8' defer onload=''></script>
<script type='text/javascript' src='https://liliputing-wpengine.netdna-ssl.com/wp-content/plugins/ultimate-social-media-icons/js/shuffle/jquery.shuffle.min.js?ver=4.8' defer onload=''></script>
<script type='text/javascript' src='https://liliputing-wpengine.netdna-ssl.com/wp-content/plugins/ultimate-social-media-icons/js/shuffle/random-shuffle-min.js?ver=4.8' defer onload=''></script>
<script type='text/javascript'>
/* <![CDATA[ */
var ajax_object = {"ajax_url":"https:\/\/liliputing.com\/wp-admin\/admin-ajax.php"};
var ajax_object = {"ajax_url":"https:\/\/liliputing.com\/wp-admin\/admin-ajax.php","plugin_url":"https:\/\/liliputing.com\/wp-content\/plugins\/ultimate-social-media-icons\/"};
/* ]]> */
</script>
<script type='text/javascript' src='https://liliputing-wpengine.netdna-ssl.com/wp-content/plugins/ultimate-social-media-icons/js/custom.js?ver=4.8' defer onload=''></script>
<script type='text/javascript' src='https://liliputing-wpengine.netdna-ssl.com/wp-includes/js/jquery/jquery.form.min.js?ver=3.37.0' defer onload=''></script>
<script type='text/javascript' src='https://www.google.com/recaptcha/api.js?onload=onloadCallback&#038;render=explicit&#038;hl=en&#038;ver=1.0.0' defer onload=''></script>
<script type='text/javascript' src='https://liliputing-wpengine.netdna-ssl.com/wp-content/plugins/wpdiscuz-recaptcha/js/wpdiscuz-recaptcha.js?ver=1.0.7' defer onload=''></script>
<script type='text/javascript' src='https://liliputing-wpengine.netdna-ssl.com/wp-includes/js/comment-reply.min.js?ver=4.8' defer onload=''></script>
<script type='text/javascript' src='https://liliputing-wpengine.netdna-ssl.com/wp-content/plugins/lazy-load/js/jquery.sonar.min.js?ver=0.6.1' defer onload=''></script>
<script type='text/javascript' src='https://liliputing-wpengine.netdna-ssl.com/wp-content/plugins/lazy-load/js/lazy-load.js?ver=0.6.1' defer onload=''></script>
<script type='text/javascript'>
/* <![CDATA[ */
var ajax_object = {"nonce":"be0105c1a6","ajaxurl":"https:\/\/liliputing.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://liliputing-wpengine.netdna-ssl.com/wp-content/uploads/cNKqedQunDmp/naiEJdZwPPxg.js?ver=2.2.1' defer onload=''></script>
<script type='text/javascript' src='https://liliputing-wpengine.netdna-ssl.com/wp-includes/js/wp-embed.min.js?ver=4.8' defer onload=''></script>
<script type='text/javascript'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://liliputing-wpengine.netdna-ssl.com/wp-content/plugins/jetpack/modules/sharedaddy/sharing.js?ver=5.1' defer onload=''></script>
<script type='text/javascript'>
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-facebook', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-twitter', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-google-plus-1', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomgoogle-plus-1', 'menubar=1,resizable=1,width=480,height=550' );
				return false;
			});
</script>
<script type='text/javascript' src='https://stats.wp.com/e-201730.js' async defer></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:5.1',blog:'4896475',post:'99142',tz:'-4',srv:'liliputing.com'} ]);
	_stq.push([ 'clickTrackerInit', '4896475', '99142' ]);
</script>
</body></html>
